Gravatar for sjef.jenniskens@achmea.nl

Question by Sjef Jenniskens, Feb 7, 2017 8:20 AM

The remote name could not be resolved: 'platform.cloud.coveo.com'

I am trying to install Coveo Cloud trial to locally develop and configure Coveo but it fails at the point where I have to login into Coveo Cloud., After a succesful login with Google, I get the error message "The remote name could not be resolved: 'platform.cloud.coveo.com' "

The details of the error message are: Server Error in '/' Application. The remote name could not be resolved: 'platform.cloud.coveo.com' Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code. Exception Details: System.Net.WebException: The remote name could not be resolved: 'platform.cloud.coveo.com' Source Error: An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below. Stack Trace: [WebException: The remote name could not be resolved: 'platform.cloud.coveo.com'] System.Net.HttpWebRequest.GetResponse() +1743 Coveo.Framework.Utils.Rest.HttpClient.ExecuteRequest(String p_Url, Func`2 p_CreateRequest, Int64 p_CallId) +334 [HttpClientException: Failed to obtain resource located at 'https://platform.cloud.coveo.com/rest/organizations'. See inner exception for details.] Coveo.Framework.Utils.Rest.HttpClient.HandleResponseException(WebException p_Exception, String p_Url, Int64 p_CallId) +392 Coveo.Framework.Utils.Rest.HttpClient.ExecuteRequest(String p_Url, Func`2 p_CreateRequest, Int64 p_CallId) +776 Coveo.Framework.Utils.Rest.HttpClient.GetRaw(String p_Url) +248 Coveo.Framework.Utils.Rest.HttpClient.Get(String p_Url) +127 Coveo.CloudPlatformClientBase.CloudPlatformClient.PerformPlatformCall(String p_HttpMethod, String p_OperationUri, String p_RequestContent) +453 Coveo.CloudPlatformClientBase.CloudPlatformClient.PerformPlatformCallWithErrorHandling(String p_RequestMethod, String p_RequestUri, String p_RequestContent) +263 Coveo.CloudPlatformClientBase.CloudPlatformClient.GetOrganizations() +347 Coveo.SearchProvider.Applications.Shell.Controls.ConfigureCoveoCloudOrganizationWizardFormPage.SetUpOrganizationList() +165 Coveo.SearchProvider.Applications.Shell.Controls.ConfigureCoveoCloudOrganizationWizardFormPage.OnPreRender(Object p_Sender, EventArgs p_E) +57 System.Web.UI.Control.OnPreRender(EventArgs e) +11937633 System.Web.UI.Control.PreRenderRecursiveInternal() +110 System.Web.UI.Control.PreRenderRecursiveInternal() +207 System.Web.UI.Control.PreRenderRecursiveInternal() +207 System.Web.UI.Control.PreRenderRecursiveInternal() +207 System.Web.UI.Control.PreRenderRecursiveInternal() +207 System.Web.UI.Control.PreRenderRecursiveInternal() +207 System.Web.UI.Control.PreRenderRecursiveInternal() +207 System.Web.UI.Control.PreRenderRecursiveInternal() +207 System.Web.UI.Control.PreRenderRecursiveInternal() +207 System.Web.UI.Control.PreRenderRecursiveInternal() +207 System.Web.UI.Control.PreRenderRecursiveInternal() +207 System.Web.UI.Control.PreRenderRecursiveInternal() +207 System.Web.UI.Control.PreRenderRecursiveInternal() +207 System.Web.UI.Control.PreRenderRecursiveInternal() +207 System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +2994

When I access "https://platform.cloud.coveo.com/" via Chrome, I get redirected to "https://platform.cloud.coveo.com/admin/" and the following message is show "You currently do not have access to any organizations."

What am I doing wrong?

Gravatar for flguillemette@coveo.com

Comment by François Lachance-Guillemette, Feb 7, 2017 10:01 AM

Since it works in Chrome, we suspect there might be a proxy that allows you to navigate through it.

Could you check if you have any proxy that you need to configure in your application?

1 Reply
Gravatar for sjef.jenniskens@achmea.nl

Answer by Sjef Jenniskens, Feb 8, 2017 6:44 AM

flguillemette with your answer I have added a default proxysetting to my web.config of my local Sitecore instance. After adding the proxysetting I could continue my Cloud Trial installation. Thank you!

Ask a question