Gravatar for indrasen45@gmail.com

Question by indrasen45, Feb 24, 2017 6:06 AM

The remote server returned an unexpected response: (405) Method Not Allowed

Hi, I am trying to configure the Coveo for my sitecore project.I configured the CES,Search Api & installed the package in sitecore instance also.it I run all the services which are related to Coveo.in the diagnostic page it shows The remote server returned an unexpected response: (405) Method Not Allowed for Admin service&enterprise search.How to resolve this issue?

Thanks in Advance.

Gravatar for lbergeron@coveo.com

Comment by Luc Bergeron, Feb 24, 2017 8:13 AM

It looks like the Coveo services are not where Coveo for Sitecore expects them to be.

Did you double check the service URLs in the Coveo for Sitecore configuration files?

Can you think of anything particular with your configuration?

Are you using the default port numbers for the Coveo services (CES, Search API, Admin Service, RabbitMQ)?

Do you have any proxy in your infrastructure?

Gravatar for indrasen45@gmail.com

Comment by indrasen45, Feb 27, 2017 3:15 AM

Hi lbergeron,

I made sure that all the services which are related to coveo(Admin,service,Diagnostic tool,enterprise search,call back service,search Api etc) are running.I am using default port numbers for coveo.Another problem is that, when I am trying to browse "http://localhost:8080/rest/search" it is asking for credentials.I tried the following credentials windows credentials,Admin credentials,Rabit mq,coveo credentials. But it is not accepting.what could be the possible solution to resolve this error? I do not have any proxy infrastructure.

0 Reply
Ask a question