Gravatar for d.graver@res.com

Question by graverd, Mar 1, 2017 12:44 PM

Error when adding Search lightning Component to Community

I am following this guide (https://onlinehelp.coveo.com/en/cloud/addingalightningcoveocomponentwiththesalesforcecommunity_builder.htm) to add the Coveo Search lightning component to our community template and keep getting an error.

Error ID: -399404134 This page has an error. You might just need to refresh it. Action failed: CoveoV2:Search$controller$onScriptLoaded [Coveo.setLanguageAfterPageLoaded is not a function] Failing descriptor: {CoveoV2:Search$controller$onScriptLoaded}

Any idea what's wrong?

Gravatar for gminero@coveo.com

Comment by gminero, Mar 1, 2017 12:59 PM

just to clarify, you get the error after drag and dropping the component on your template? after you close the popup with the error, what happens?

Gravatar for maveilleux@coveo.com

Comment by maveilleux, Mar 1, 2017 1:12 PM

Do you have locker service enabled?

Gravatar for d.graver@res.com

Comment by graverd, Mar 1, 2017 1:13 PM

Yes after after i drag and drop. I tried refreshing and deploying but nothing shows up.

Gravatar for gminero@coveo.com

Comment by gminero, Mar 1, 2017 1:47 PM

as mentioned by maveilleux, check under setup - critical updates: make sure Enable Lightning LockerService Security is NOT ACTIVATED.

Gravatar for d.graver@res.com

Comment by graverd, Mar 1, 2017 2:11 PM

Solved it! Thanks!

1 Reply
Gravatar for gminero@coveo.com

Answer by gminero, Mar 1, 2017 3:51 PM

Under setup - critical updates: make sure Enable Lightning LockerService Security is NOT ACTIVATED. alt text

Ask a question