Gravatar for mwashburn@forcepoint.com

Question by kurgen, Mar 6, 2017 11:33 AM

Articles marked internal only still showing up on public side

Hello all,

In our environment, we have roughly 62 articles that are marked internal only within Salesforce but are still showing up on our website when searched by an anonymous public user without a login to our site. We have thousands of articles within the same repository that are marked the same way that work as expected. I know standard practice of Coveo is to not even display the article when marked internal only. The user can click on the article which then re-directs them to to login page which is good, but they should not even be able to see the article in the first place. I am new to Coveo and this is a task I was handed to figure out and would love some feedback on where to begin to resolve this issue. This question may be kind of vague and broad but any help would be appreciated.

Thank you in advance.

Gravatar for gminero@coveo.com

Comment by gminero, Mar 6, 2017 2:29 PM

Have you configured the advanced lightning configuration? Please view our documentation for further details: https://onlinehelp.coveo.com/en/cloud/addingserver-sidecoveolightningcomponent_configuration.htm and let us know if you have any questions

Gravatar for mwashburn@forcepoint.com

Comment by kurgen, Mar 10, 2017 12:57 PM

The advanced lightning configuration has been configured and we have 4 flags marked on our KB articles (Internal App, Partner, Customer and Public Knowledge Base). The field level security being placed onto the query is @syschannelsmerged=CustomerPortal:True which i believe is merging all the channels instead of implementing our security features of these flags. I am not sure where this code would reside or how to confirm this yet however unless anybody has any ideas.

0 Reply
Ask a question