Gravatar for gling@houstonmethodist.org

Question by qch1595, May 18, 2017 3:19 PM

Sitecore published items not getting updated in Coveo search results

We have Sitecore 8.2 and Coveo for Sitecore 4.0. When we created a new item in Sitecore and published it, it got updated in Coveo search results automatically. But when we went back to modify the item and published it again, it was not updated in Coveo.

Gravatar for sbelzile@coveo.com

Comment by Sébastien Belzile, May 18, 2017 4:47 PM

  1. Coveo for Sitecore version?
  2. Cloud or on-premises?
  3. Anything or in your logs?
  4. No workflow preventing your item from being published? (your item was indeed published to the web DB?)
1 Reply
Gravatar for gling@houstonmethodist.org

Answer by qch1595, May 18, 2017 8:32 PM

It is my mistake. There is a bug in my code. It worked right after I fixed the bug. Thanks!

Gravatar for flguillemette@coveo.com

Comment by François Lachance-Guillemette, May 23, 2017 12:02 PM

Could you share us what was the bug in question and how you solved it? It might help other people :)

Gravatar for gling@houstonmethodist.org

Comment by qch1595, May 23, 2017 1:15 PM

I have some code handles Sitecore event: publish:complete. It uses Sitecore.Context.Database. Somehow, it got an "Object reference null instance" error which blocks the whole publish process after publishing changes. So I replaced it with Sitecore.Configuration.Factory.GetDatabase("web") and the problem is solved.

Also, I found another article mentioned this is a known Sitecore issue. It could be fixed by running iisreset. But my Sitecore 8.2.1 doesn't have this issue. It was my code issue. Thanks.

Ask a question