Gravatar for jfvalois@absolunet.com

Question by jfvalois, Sep 29, 2014 3:56 PM

Install package + License

Hi!

We installed the Coveo for Sitecore Free Edition package and the coveolicense.xml was installed at C:\Appdata\data. Should the license be installed in the website\Appdata\data with the others licenses? With the current path, we can't have more than one license per server/desktop.

1 Reply
Gravatar for jflheureux@coveo.com

Answer by Jean-François L'Heureux, Sep 29, 2014 4:13 PM

The Coveo for Sitecore license is saved at the same location than the Sitecore license. It's one Coveo for Sitecore license per Sitecore instance.

Why do you need to have more than one license per Sitecore instance?

Gravatar for vseguin@coveo.com

Comment by Vincent Séguin, Sep 29, 2014 6:02 PM

The same location of the Sitecore license is typically Instance\Data folder… Did you change your Data folder location?

Gravatar for jfvalois@absolunet.com

Comment by jfvalois, Sep 29, 2014 8:26 PM

We didn't change our data location. Our sitecore license is still in the "projectwebsite\Appdata\data".

Since the coveolicense.xml was in the C:\App_data\data, every sitecore projet on the server (development server) had the same license.

Gravatar for vseguin@coveo.com

Comment by Vincent Séguin, Sep 30, 2014 7:37 AM

To select the license location, we use this : Settings.DataFolder from Sitecore. This points to the Web.config file… somethings like sc.variable name="dataFolder" value="C:\Inetpub\wwwroot\Sitecore71u2\Data\"

Can you confirm what is in your web.config?

Gravatar for jfvalois@absolunet.com

Comment by jfvalois, Sep 30, 2014 10:31 AM

This is what we have in the web.config

Gravatar for vseguin@coveo.com

Comment by Vincent Séguin, Sep 30, 2014 10:50 AM

And for the setting name="DataFolder" value="$(dataFolder)" , what do you have?

Gravatar for jfvalois@absolunet.com

Comment by jfvalois, Sep 30, 2014 10:57 AM

Same as you

Gravatar for vseguin@coveo.com

Comment by Vincent Séguin, Oct 1, 2014 12:55 PM

Is it possible to change the value of the dataFolder of your site?

Gravatar for slangevin@coveo.com

Comment by Simon, Apr 30, 2015 8:26 AM

There was an issue with relative paths declared in the web.config. The relative path pointing from the website root were not considered. This has been fixed in May 2015.

Ask a question