Gravatar for sohelsd@gmail.com

Question by sohel, Oct 14, 2014 11:22 AM

Cannot access localhost/AdminService

I tried both http://localhost/AdminService and https://localhost:443/AdminService (also tried setting an ssl cert per this doc) but I get this configuration error: The configuration section 'coveoCnlWeb' cannot be read because it is missing a section declaration

2: configuration>
3:  coveoCnlWeb>
4:     customContent uri="~/Coveo/" anonymousUri="~/Coveo/Anonymous/"/>
Gravatar for lbergeron@coveo.com

Comment by Luc Bergeron, Oct 14, 2014 11:43 AM

Hi,

It seems a little confused. The "coveoCnlWeb" configuration section is not used by Coveo for Sitecore or the Admin Service. Can you give the link of the doc you are referring to?

For the Admin Service, it should have been installed with the Coveo Search Index. First, you can check your windows services. You should see "Coveo Admin Service". Ensure it is started and it runs with the same user as the "Coveo Enterprise Search 7" service.

If the "Coveo Admin Service" is not there, rerun the CES installer (modify) and make sure the "Admin Service" feature is enabled.

Hope this helps

2 Replies
Gravatar for sohelsd@gmail.com

Answer by sohel, Oct 21, 2014 12:09 PM

The issue was I was not setting the ssl cert on the port properly. After carefully following the documentation at https://developers.coveo.com/display/public/SC201409/Configuring+a+Secured+Admin+Service I was able to get this issue resolved.

Gravatar for boboydot@gmail.com

Answer by sahaeta9, Dec 15, 2016 7:04 AM

To Determine Which Port Number the Server Is Using

Examine the server's configuration file:

as-install/domains/domain1/config/domain.xml

Find the network-listener element.
Inspect the value of the port attribute.

Be sure to enter the correct port number when invoking the server.
by. [optonline][1]
Ask a question