Gravatar for jesse.a.kearns@gmail.com

Question by jkearns, Oct 31, 2014 12:04 PM

REST Endpoint 500 Error with CES on remote server

I had a similar issue the other day (https://answers.coveo.com/questions/1054/rest-endpoint-500-error) but the solution from before is not solving my issue.

CES is installed on a separate server from my Sitecore instance. The Coveo diagnostics page says "Coveo Search REST Endpoint () - The remote server returned an error: (500) Internal Server Error" This is the only error on this page. I am able to rebuild indexes, but when I go to search in content editor I get 0 results and when I preview a Coveo search page I get the generic "Oops! Something went wrong on the server." error message.

My CES revision number is 7104, the revision number of the Sitecore package I installed is 742, I tried the previous solution of stopping CES, deleting the license file, restarting CES and re-indexing, and the license info listed in CES has "SharePoint Search Interface, Default Search Interface" listed under Available Search Interfaces, leading me to believe this is not the same error as the other day. I do not get this error when I use an instance of CES on the same server as the Sitecore instance with the same revision number.

Has anyone experienced this error before?

Gravatar for mlaporte@coveo.com

Comment by Martin Laporte, Oct 31, 2014 12:10 PM

You should check the browser console and/or the Network tab. More information about what is causing the Oops should be available there.

2 Replies
Gravatar for jesse.a.kearns@gmail.com

Answer by jkearns, Oct 31, 2014 3:11 PM

I took mlaporte's suggestion, turns out I had changed the path to the certificate file in one location in my config file but not in another place. Once I fixed that the error disappeared.

Gravatar for vseguin@coveo.com

Answer by Vincent Séguin, Oct 31, 2014 1:30 PM

Hi,

The 500 is usually by an error underneath. Is there anything in the Sitecore logs when you access the erronous page?

Ask a question