Gravatar for corrac@paragon-inc.com

Question by Cris Corra, Nov 4, 2014 8:14 AM

Sort by systitle does not sort resultslist correctly.

I am trying to add a sort component to my search that uses the systitle field. I have added it to the search control directly:

Alpha

However, the items are not sorting as expected: http://cl.ly/image/450p3O1e2q3h/Windows7VSNET2013.png

The console is showing the sortCriteria and sortField are set correctly: http://cl.ly/image/0r3e31160e1H/Windows7VSNET2013.png

Coveo for Sitecore 72 - Advanced Search Edition 3.0 (558) (July 2014 release). Coveo Enterprise Search 7.0 x64 (6830)

2 Replies
Gravatar for dlavoie@coveo.com

Answer by Daniel Lavoie, Nov 4, 2014 8:50 AM

Hi, In order for sort on string fields to work properly, you first need to configure the field as a sort field in the configuration (Administration Tool / Configuration / Fields / Your Field Set / Your Field / Sort check box.

Unfortunately, you will need to rebuild your source for the change to take effect. Newer builds no longer require a recrawl when setting a sort or facet field (September 2014 and up).

Hope this helps.

Gravatar for vseguin@coveo.com

Comment by Vincent Séguin, Nov 4, 2014 8:52 AM

Indeed, Dan is right, @systitle is not sortable by default. Actually, the configuration for this field will be found under Administration Tool / Configuration / Fields / Your Field Set / System Fields / systitle / Sort check box.

Gravatar for corrac@paragon-inc.com

Comment by Cris Corra, Nov 4, 2014 8:54 AM

Yes, this is what the issue was. I had changed the sort option for systitle, but hadn't rebuilt the index. Thanks for your help and quick response!

Gravatar for corrac@paragon-inc.com

Comment by Cris Corra, Nov 4, 2014 8:56 AM

Also guys, is there a way to specify systitle in the Sort rendering component's properties? I could not find that option.

Gravatar for mlaporte@coveo.com

Comment by Martin Laporte, Nov 4, 2014 9:24 AM

I'm not sure I understand your question --- wasn't this already done for you to get the console screenshots above? I'm confused :)

Gravatar for vseguin@coveo.com

Answer by Vincent Séguin, Nov 4, 2014 8:48 AM

Hello Cris,

In the first picture, is it possible that it's not @systitle that is currently displayed? Could it be another field, making the impression that the sort is not working?

Gravatar for corrac@paragon-inc.com

Comment by Cris Corra, Nov 4, 2014 8:55 AM

Thanks for the quick response! I should have noted in my post that I was certain systitle was being shown in the listing.

Ask a question