Gravatar for deepak.raghav87@gmail.com

Question by deepak_raghav, Nov 6, 2014 4:37 AM

Coveo Error while rebuilding the source assigned to the collection

I have created a collection and i'm assigning a source for the collection. I have given 'Active Directory' as my security provider. and the Document type is selected as 'Web pages' for the collection Now When i tired to rebuild the source the documents are not getting indexed. In the logs section the following error is shown.

IMPORTANT 03:32:55 AM The source Sample rebuild was stopped. HoustonSampleCollection Sample ERROR 03:32:55 AM … at Coveo.CES.CustomCrawlers.CustomCrawler.RefreshThread() HoustonSampleCollection Sample ERROR 03:32:55 AM … at Coveo.CES.CustomCrawlers.ActiveDirectory.Connector.PrepareCrawling(Boolean pIsLiveIndexing) HoustonSampleCollection Sample ERROR 03:32:55 AM … at Coveo.CES.CustomCrawlers.ActiveDirectory.Connector.StartCrawling(Boolean pIsLiveIndexing) HoustonSampleCollection Sample ERROR 03:32:55 AM … at System.DirectoryServices.DirectorySearcher.FindAll(Boolean findMoreThanOne) HoustonSampleCollection Sample ERROR 03:32:55 AM … at System.DirectoryServices.DirectoryEntry.get_AdsObject() HoustonSampleCollection Sample ERROR 03:32:55 AM … at System.DirectoryServices.DirectoryEntry.Bind() HoustonSampleCollection Sample ERROR 03:32:55 AM … at System.DirectoryServices.DirectoryEntry.Bind(Boolean throwIfFail) HoustonSampleCollection Sample ERROR 03:32:55 AM … System.Runtime.InteropServices.COMException (0x80005000): Unknown error (0x80005000) HoustonSampleCollection Sample ERROR 03:32:55 AM Active Directory Error: Unknown error (0x80005000) HoustonSampleCollection Sample IMPORTANT 03:32:55 AM Rebuilding the source Sample.

Please let me know how to resolve this issue and get a search working in coveo.

1 Reply
Gravatar for mlaporte@coveo.com

Answer by Martin Laporte, Nov 6, 2014 4:42 AM

Hmm from the look of your call stack you are using the ActiveDirectory connector which is something that indexes People documents off an AD server. It's not the same thing as using the ActiveDirectory security provider on a source using another connector.

Gravatar for deepak.raghav87@gmail.com

Comment by deepak_raghav, Nov 10, 2014 7:46 AM

We need the Sitecore Connector to crawl through the Contents in Sitecore. But it is not currently available in the Allowed sources. Is there any way to add it or it does not come in a free edition. I'm currently using a free edition coveo for sitecore.

Gravatar for vseguin@coveo.com

Comment by Vincent Séguin, Nov 10, 2014 8:04 AM

Please read the documentation on developers.coveo.com.

Gravatar for cbolduc@coveo.com

Comment by Carl Bolduc, Nov 10, 2014 10:30 AM

Reading your other questions and the details you have shared here, it looks like you have installed both the Coveo back-end and the Coveo for Sitecore plugin. You are now ready to rebuild your Sitecore index.

Please follow the instructions described here.

Two important points:

  • The Coveo for Sitecore free edition only comes with the Queue Connector, this is the connector used by the Sitecore integration that pushes content to Coveo at indexing time;
  • There is nothing to do in the Coveo Administration Tool, everything happens in Sitecore.
Ask a question