Gravatar for mkrimi@absolunet.com

Question by mohamed krimi, Nov 21, 2014 1:56 PM

Wich is the best way to make Coveo for sitecore search in all fields instead Title field ?

Hi, We use Coveo for Sitecore. By default Coveo searches for keyword into the title field. How can we make it searches into all custom fields ?

Thank you.

4 Replies
Gravatar for mkrimi@absolunet.com

Answer by mohamed krimi, Dec 1, 2014 1:55 PM

I use the Coveo Search Page in the page preview mode. I'm testing the sitecoremasterindex. In CES Admin interface, Cached is a blank page pop-up No summary in the Summary Tab. Hope this will help you.

Thank you.

Gravatar for jflheureux@coveo.com

Comment by Jean-François L'Heureux, Dec 1, 2014 3:27 PM

Can you verify the "indexed date" of the documents in the Index Browser? Is it the date of your last re-index of the Master database items? If it is older, you likely have indexing problems and should check the Sitecore logs. Activating the Coveo for Sitecore logs would also be a good idea in that case (see Using Logging for Debugging Purposes).

Gravatar for jflheureux@coveo.com

Comment by Jean-François L'Heureux, Dec 1, 2014 3:27 PM

Can you double-check the procedure to configure the basic HTML content. Verify that:

  • You put the processor in the coveoPostItemProcessingPipeline pipeline.
  • There's no following processor in this pipeline that can overwrite the item's binary data.
  • There's no previous processor in this pipeline that is setting the item's binary data.
  • You either didn't specify the TemplatesToInclude or that you set the right template names in it.
Gravatar for mkrimi@absolunet.com

Comment by mohamed krimi, Dec 2, 2014 11:49 AM

Hi JF,

  • The processor is in the coveoPostItemProcessingPipeline pipline,
  • No other processor in the same pipeline,
  • No previous processor in the pipeline,
  • No TemplatesToInclude

In the CES Admin Index documents are updated correctly (Double checked the date/time field) and crawled as Basic HTML content (There is the icon). No error in Coveo Diagnostic Page and Sitecore Diagnostics Logs.

Gravatar for mkrimi@absolunet.com

Comment by mohamed krimi, Dec 4, 2014 2:53 PM

Hi JF, After some tests, I noticed that for some reason we can not combine TemplatesToInclude with IncludeTextFieldsOnly or FieldsToInclude. The option that works for us is to put only ''FieldsToInclude'' as Processor option.

Thank you a lot for your help..

Gravatar for jflheureux@coveo.com

Comment by Jean-François L'Heureux, Dec 4, 2014 3:18 PM

From the code, it seems that TemplatesToInclude is independent of the other options. However, FieldsToInclude and IncludeTextFieldsOnly options are dependent.

By default, all non-system fields are included in the HTML content. Then, if FieldsToInclude option is specified, we reduce the fields to include to keep only those fields (if they exist on the item). Then, if IncludeTextFieldsOnly option is specified and set to true, we reduce the fields to include to keep only the text fields.

I hope this helps you to configure your processor to your needs.

Gravatar for jflheureux@coveo.com

Answer by Jean-François L'Heureux, Nov 21, 2014 2:09 PM

By default, Coveo for Sitecore searches for keywords in all free-text fields and in the documents body.

To have the free-text search to look in more fields, you can either:

Gravatar for mkrimi@absolunet.com

Answer by mohamed krimi, Nov 28, 2014 5:05 PM

Hi JF,

Thank you for your replay. I tried using Indexing Documents with Basic HTML Content. But i'm not sure about. It is not working for us.

Here is my config file : true

Thanks for your help.

Gravatar for jflheureux@coveo.com

Comment by Jean-François L'Heureux, Dec 1, 2014 9:00 AM

IncludeTextFieldsOnly must follow the same casing as in the documentation with capital I, T, F and O letters.

Gravatar for mkrimi@absolunet.com

Comment by mohamed krimi, Dec 1, 2014 11:09 AM

Hi JF,

Sorry about the copy/paste miss. This is what we have :

true Instruments de mesure, Programmes et outils

Thank you.

Gravatar for mkrimi@absolunet.com

Comment by mohamed krimi, Dec 1, 2014 11:27 AM

Hi JF, This is a copy/paste miss. In our config file we have IncludeTextFieldsOnly with I, T, F, O. Thank you.

Gravatar for mkrimi@absolunet.com

Comment by mohamed krimi, Dec 1, 2014 11:29 AM

true reference,TypeDeProgramme,PrecisionsSurLaClienteleVisee,Utilisateurs,ButsEtObjectifs Instruments de mesure,Programmes et outils

Gravatar for vseguin@coveo.com

Comment by Vincent Séguin, Dec 1, 2014 12:52 PM

Hi Mohamed,

What do you mean by 'it's not working' ? With more details we could investigate further. I think setting the fields as freetext is probably a good option as well.

Gravatar for mkrimi@absolunet.com

Answer by mohamed krimi, Dec 1, 2014 1:08 PM

Hi Vincent,

The search returns 0 result for test keyword from other field (not title field).

We try to use Basic HTML Content Indexing Documents because we have more than one custom Sitecore template and each template has more than 40 custom text field.

But I also tried to activate FreeText with one of custom field like this : 1- (Note that lower case is caused by the copy/paste into this comment field) 2- Rebuild index 3- Test => Negative.

Thank you.

Gravatar for jflheureux@coveo.com

Comment by Jean-François L'Heureux, Dec 1, 2014 1:44 PM

Which indexes do you rebuild when re-indexing the items? From which search page do you execute your queries? Is it in the published web site, in the Page Editor mode, in the Page Preview mode?

You can verify the content of the indexed documents in the Index Browser (see Finding Documents Using the Index Browser). Find a document that should have the fields in its body and click on its "Cached" or "QuickView" link to see its indexed content.

Ask a question