Gravatar for diego.moretto@xcentium.com

Question by Diego, Jan 15, 2015 3:03 PM

Coveo for sitecore won´t bring results

On the admin tool I see the results when I query on a specific index but not in sitecore when searching. I checked the CES Console tool and I see that it is trying to query the index but get 0 results. How should my url be to set the query to run on a specific index?

if I run like this I see other results from other indexes. http://sitecore.dev.website/coveo/rest/?q=mykeyword

also what could be going wrong here? Why coveo for sitecore wont return the results? thanks

2 Replies
Gravatar for slangevin@coveo.com

Answer by Simon, Jan 15, 2015 3:19 PM

Take a look at the CES Console when querying, it should return the identity of the user. Then, compare it with the permissions applied to the document in the Admin Tool >> Index Browser (Details >> Permissions).

It might show a security mismatch.

Simon

Gravatar for diego.moretto@xcentium.com

Comment by Diego, Jan 15, 2015 3:56 PM

When I open the documents in the admin tool on the properties I see:

You do not have the permissions to view the document properties.

I then added my domain user which is the one I'm using to access the tool, on the Roles area as System Administrator and restarted all coveo services(in case of cache) but still I see this message. maybe that´s the cause?

So this looks like the problem is not with coveo for sitecore per say but my user doesn´t have permissions to see the documents is that correct?

Gravatar for slangevin@coveo.com

Comment by Simon, Jan 15, 2015 4:01 PM

Add your Coveo user in the Configuration >> Roles section of the Administration Tools. You need System Administrator Index (Full Access) << REALLY IMPORTANT

Then you will be able to see the permissions. Simon

Gravatar for diego.moretto@xcentium.com

Comment by Diego, Jan 16, 2015 8:05 AM

Ok I can see the permissions now. this is what I see: No user or group to display

there is an arrow which I can click and I see this: CUSTOM SOURCE PERMISSIONS Set 1 ADMINISTRATOR LEVEL Administrator Set PARENT : 3 ROLE LEVEL Parent : 3 Role Set PARENT : 3 DENIED INHERITANCE LEVEL Parent : 3 Denied Inheritance Set PARENT : 4 ROLE LEVEL Parent : 4 Role Set PARENT : 6 ROLE LEVEL Parent : 6 Role Set OWNER LEVEL Owner Set

I'm sensing there should be Anonyumous permissions for this document. On sitecore the extranet/Anonymous user has read privileges and it is indexed. Any ideas?

Gravatar for slangevin@coveo.com

Comment by Simon, Jan 16, 2015 10:58 AM

You are correct, Anonymous should be allowed, my feeling is a break during the cache refresh. Here how you could prove it:

  • Open the CES Console to track the operations in Coveo
  • Refresh the security cache: http://onlinehelp.coveo.com/en/ces/7.0/Administrator/refreshingsecuritycaches.htm
  • Post any errors returned in the Console

Thank you

Gravatar for diego.moretto@xcentium.com

Answer by Diego, Jan 16, 2015 1:20 PM

refreshing the cache worked

Ask a question