Gravatar for diego.moretto@xcentium.com

Question by Diego, Feb 17, 2015 1:28 PM

Admin Service not working

Hello

I'm installing coveo in a sitecore instance and when I run the diagnostics page I get several erros on the admin service:

There was no endpoint listening at http://localhost/AdminService that could accept the message. This is often caused by an incorrect address or SOAP action. See InnerException, if present, for more details.

in fact opening localhost/adminservice returns a 404. I read that this might be related to credentials so I repaired the installation the the enterprise search and provided a local user with admin privileges but that didn´t fix the issue. One thing that I thought weird was that whenever I try to repair the installation the installer shows that the admin service security option is disabled like if that was never done. Also all coveo services are running. Any ideas what could be causing this?

thanks

2 Replies
Gravatar for slangevin@coveo.com

Answer by Simon, Feb 17, 2015 1:48 PM

Hi,

404 is a not found error, not a credential problem.
If your admin service is secured, then your endpoint should be on https, not http.

So is https://localhost:443/AdminService returning anything?

Cheers,
Simon

Gravatar for diego.moretto@xcentium.com

Comment by Diego, Feb 17, 2015 2:35 PM

Hey Simon. no that url doesn´t return anything. just a "This page can´t be displayed"

Gravatar for diego.moretto@xcentium.com

Comment by Diego, Feb 17, 2015 2:48 PM

Reinstalling it worked although it´s not secured but for now it´s not complaining anymore

Gravatar for slangevin@coveo.com

Comment by Simon, Feb 17, 2015 4:46 PM

If you are securing the admin service, chances are that you will need to create a self signed certificate. See the troubleshooting section of this guide:

https://developers.coveo.com/display/SC201502/Securing+the+Admin+Service

It is not a user friendly process for the moment but we are planning on making this easier.

Gravatar for anweshadastider@gmail.com

Comment by anwesha, Jul 23, 2015 3:59 AM

I am facing exactly the same issue. Please let me know if anything resolved this issue for you.

Gravatar for slangevin@coveo.com

Comment by Simon, Jul 23, 2015 6:35 AM

Hi, is your Admin Service running on port 443? Then you are indeed using a secured admin service and the troubleshooting can be found here: https://developers.coveo.com/display/SC201502/Securing+the+Admin+Service

If you are not using a secured admin service, then I guess this thread is not the right one for you and I would suggest to post a new question with the error you are seeing.

Cheers
Simon

Gravatar for lbergeron@coveo.com

Answer by Luc Bergeron, Feb 17, 2015 1:45 PM

Hi,

I understand you are running the Admin Service in secured mode. When in secured mode, you should use "https://localhost/AdminService" to connect to the service. Also, in the Coveo.SearchProvider.config file, set the values for the "Username" and "Password" elements (inside "adminServiceConfiguration" element). You must set the same user name and password that you set through the Coveo Enterprise Search installer. This should get you going.

You can also refer to this page for configuration details: https://developers.coveo.com/display/SC201502/Securing+the+Admin+Service

Hope this helps

Gravatar for diego.moretto@xcentium.com

Comment by Diego, Feb 17, 2015 2:05 PM

thank you. What if I don´t need to run it in secured mode? I tried to repair the installation without the secured mode but that didn´t seem to fix it :(

Gravatar for lbergeron@coveo.com

Comment by Luc Bergeron, Feb 17, 2015 2:12 PM

That's weird. You can try to "modify", remove the Admin Service feature. Then you re-run the installer and install the feature again.

Ask a question