Gravatar for erkan.yildiz@avanade.com

Question by erkany, Mar 18, 2015 2:01 PM

/Coveo/Rest returns 503 Service not available

Hi,

I have a multi server Sitecore install. Coveo is installed on CA server.

From one of the CD servers I can't access to http:[CDServerURL]/coveo/rest - I get 503 : The service is unavailable

I can access to CA server admin service and CoveoSearchService fine from the problematic "CD" server.

http://[Caserver]/AdminService http://[Caserver]:52810/7.0/CoveoSearchService

Works fine.

I checked Rest.Config and verified I am pointing to the right server and port number. This works for other CD servers so I assume config.YML is fine ( allowimpersonate etc.. )

Any ideas?

1 Reply
Gravatar for lbergeron@coveo.com

Answer by Luc Bergeron, Mar 18, 2015 2:03 PM

Does the application secret specified in Coveo.SearchProvider.Rest.config matches with the one in config.yml?

Gravatar for erkan.yildiz@avanade.com

Comment by erkany, Mar 18, 2015 2:05 PM

Yeap - I pretty much copied all coveo configs from a working CD server

Gravatar for slangevin@coveo.com

Comment by Simon, Mar 18, 2015 2:14 PM

Ok but [CoveoMachineName]:[PORT]/rest/search , does it resolve?

Gravatar for erkan.yildiz@avanade.com

Comment by erkany, Mar 18, 2015 2:34 PM

http://snf-sc-stg-ca:8087/rest/search -- shows "the page can't be displayed" . But I can't view this page from other CDs as well.

the public site URL/coveo/rest works for other CDs though. So not sure what is going on with the 3rd CD server

Gravatar for erkan.yildiz@avanade.com

Comment by erkany, Mar 18, 2015 3:39 PM

looks like it was a port issue . You guys really need a better installation/configuration and troubleshooting tool. Lots of components and a lot of text config to look

Gravatar for slangevin@coveo.com

Comment by Simon, Mar 18, 2015 3:51 PM

https://developers.coveo.com/display/public/SupportKB/How+to+-+Check+if+the+ports+used+by+Coveo+for+Sitecore+are+opened+on+the+remote+CES+Server

Ask a question