Gravatar for nicolas.a.slavik@accenture.com

Question by yonico, Mar 18, 2015 5:46 PM

MetaKeywords is not being search

Hi - I am investigating why the field we have set in sitecore is not being searched. The name is MetaKeywords and I was looking into this to know why we dont get any results regarding this when making searches. Is there a way to know what are fields use in the search engine to make sure we are not including this? I dont know if this is something coveo should do automatically or if I need to setup this manually.

1 Reply
Gravatar for lbergeron@coveo.com

Answer by Luc Bergeron, Mar 19, 2015 8:34 AM

I guess the field you are looking at does not have Free Text Search enabled. You can validate it by looking at the field set in the CES Admin Tool (Configuration > Fields). See the column entitled "Free Text Queries".

With Coveo for Sitecore, you can enable the Free Text Search on a field via the field map, by setting the "includeForFreeTextSearch='true'" attribute. So, in Coveo.SearchProvider.config, the element will look like this:

<fieldNames hint="raw:AddFieldByFieldName">
    <fieldType fieldName="yourSitecoreFieldName" includeForFreeTextSearch="true" settingType="Coveo.Framework.Configuration.FieldConfiguration, Coveo.Framework" />
</fieldNames>

See this page for more details: https://developers.coveo.com/display/public/SC201503/Understanding+the+Coveo+Search+Provider%27s+Configuration+File

I hope this helps

Ask a question