Gravatar for anjo.iypejoseph@accenture.com

Question by anjoiype, Apr 14, 2015 8:52 AM

Cannot open CES admin Console

I installed CES in a single server system. After installing when I tried to take the initial index creation screen it came successfully and after that I created index in C:/CES7 folder. After this step when ever I try to open admin console of CES (Start-->All programs-->CES7--. CES admin tool) I am getting the following error

"Error HRESULT E_FAIL has been returned from a call to a COM component. "

My Stack trace is as follows:

System.Runtime.InteropServices.COMException (0x80004005): Error HRESULT E_FAIL has been returned from a call to a COM component.
   at Coveo.CES.Interops.CESAdmin.LicenseClass.get_AudioVideoInstalled() 
   at Coveo.CES.Admin.CesLicense.get_AudioVideoInstalled() 
   at Coveo.CES.Web.Admin.Configuration.License.License.OnInit(EventArgs p_Args) 
   at System.Web.UI.Control.InitRecursive(Control namingContainer) 
   at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)

Please provide me a solution. Thanks in advance

1 Reply
Gravatar for slangevin@coveo.com

Answer by Simon, Apr 14, 2015 9:25 AM

Hi,

The might be something wrong in your license file. Maybe an invalid char got inserted during a copy.

I would advise to contact Coveo support to validate and re-issue the license if needed.

Cheers,
Simon

Gravatar for anjo.iypejoseph@accenture.com

Comment by anjoiype, Apr 15, 2015 1:05 AM

Thanks for your answer. When I go to sitecore control panel and check the license details its showing every details correctly. So how can i check whether my license is wrong or not.

Gravatar for slangevin@coveo.com

Comment by Simon, Apr 15, 2015 9:01 AM

I am not sure I understand. You are seeing the error when starting the CES Adminstration Tools, but still you can view the license menu?

Gravatar for anya.mudry@alpa.org

Comment by searchdev, May 7, 2015 12:06 PM

I am getting exactly the same error. Yes, the error occurs when I attempt to access to CES Admin Tool. License when viewed via Sitecore looks fine.

Anyone has a solution?

Ask a question