Gravatar for anjo.iypejoseph@accenture.com

Question by anjoiype, Apr 15, 2015 7:25 AM

Error while accesing Index manager in in sitecore

I installed Coveo and when I try to run the indexing manager in Sitecore I am getting an error given below.

Coveo Entreprise Search seems to be unavailable. Please make sure that the service is installed and started.

Given below the stack trace:

[CesUnavailableException: Coveo Entreprise Search seems to be unavailable. Please make sure that the service is installed and started.]
   Coveo.AdminService.AdminServiceClientWrapper.TryHandleFaultException(FaultException`1 p_Exception) +87
   Coveo.AdminService.AdminServiceClientWrapper.PerformAdminServiceCall(Func`1 p_Func) +200
   Coveo.AdminService.AdminServiceClientWrapper.IsFirstTimeSetupDone() +95
   Coveo.AbstractLayer.Communication.CES.AdminModule.InitializeCes() +92
   Coveo.AbstractLayer.Communication.CES.CESCommunication.InitializeCes() +70
   Coveo.SearchProvider.ProviderIndexBase.Initialize(IIndexDocumentPropertyMapper`1 p_DocumentTypeMapper) +2161
   Coveo.SearchProvider.ProviderIndex.Initialize() +131
   Coveo.SearchProvider.Configuration.CoveoSearchConfiguration.AddIndex(ISearchIndex p_Index) +204

[TargetInvocationException: Exception has been thrown by the target of an invocation.]
   System.RuntimeMethodHandle.InvokeMethod(Object target, Object[] arguments, Signature sig, Boolean constructor) +0
   System.Reflection.RuntimeMethodInfo.UnsafeInvokeInternal(Object obj, Object[] parameters, Object[] arguments) +76
   System.Reflection.RuntimeMethodInfo.Invoke(Object obj, BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture) +211
   System.Reflection.MethodBase.Invoke(Object obj, Object[] parameters) +35
   Sitecore.Configuration.Factory.AssignProperties(Object obj, Object[] properties) +832
   Sitecore.Configuration.Factory.AssignProperties(XmlNode configNode, String[] parameters, Object obj, Boolean assert, Boolean deferred, IFactoryHelper helper) +759
   Sitecore.Configuration.Factory.CreateObject(XmlNode configNode, String[] parameters, Boolean assert, IFactoryHelper helper) +296
   Sitecore.Configuration.Factory.CreateObject(String configPath, String[] parameters, Boolean assert) +666
   Sitecore.ContentSearch.ContentSearchManager.get_SearchConfiguration() +261
   Sitecore.ContentSearch.Client.Forms.IndexingManagerWizard.BuildIndexes() +163

[TargetInvocationException: Exception has been thrown by the target of an invocation.]
   System.RuntimeMethodHandle.InvokeMethod(Object target, Object[] arguments, Signature sig, Boolean constructor) +0
   System.Reflection.RuntimeMethodInfo.UnsafeInvokeInternal(Object obj, Object[] parameters, Object[] arguments) +76
   System.Reflection.RuntimeMethodInfo.Invoke(Object obj, BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture) +211
   System.Reflection.MethodBase.Invoke(Object obj, Object[] parameters) +35
   Sitecore.Web.UI.Sheer.ClientPage.OnLoad(EventArgs e) +337
   System.Web.UI.Control.LoadRecursive() +71
   System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +3178

I tried all the steps given in link: link text but nothing worked. Added to it when I try to run coveo api services it is getting stopped automatically after some seconds. Log says valid services were not found.

when I run http://localhost/adminservices in my browser I am getting the following output.

You have created a service.

To test this service, you will need to create a client and use it to call the service. You can do this using the svcutil.exe tool from the command line with the following syntax:

svcutil.exe http://localhost/AdminService?wsdl

You can also access the service description as a single file:

http://localhost/AdminService?singleWsdl

This will generate a configuration file and a code file that contains the client class. Add the two files to your client application and use the generated client class to call the Service. For example:

Kindly help me to resolve this issue.. Thanks in advance.

1 Reply
Gravatar for vseguin@coveo.com

Answer by Vincent Séguin, Apr 15, 2015 7:54 AM

Hi,

This is probably related to the other question you asked here : https://answers.coveo.com/questions/2969/cannot-open-ces-admin-console

You could get more infos by looking at the AdminService logs. Those are located under C:\Program Files\Coveo Enterprise Search 7\bin\AdminService*.log (this take into account you installed CES in the Program Files folder.)

Gravatar for anjo.iypejoseph@accenture.com

Comment by anjoiype, Apr 15, 2015 9:06 AM

In that log it says

  • An exception occurred when trying to retrieve the host name from AWS. System.Net.WebException: Unable to connect to the remote server ---> System.Net.Sockets.SocketException: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond 169.254.169.254:80 at System.Net.Sockets.Socket.DoConnect(EndPoint endPointSnapshot, SocketAddress socketAddress). It an amazon server.
Gravatar for vseguin@coveo.com

Comment by Vincent Séguin, Apr 15, 2015 9:09 AM

This error is normal and can be ignored. It is only related to the fact the AdminService is also used by the Coveo Cloud platform. So i highly suspect it is related to your other error. Also, is the Search API service up and running?

Ask a question