Gravatar for puneetpande@gmail.com

Question by ppande, May 7, 2015 2:31 PM

I keep getting FailedToImpersonateUsersException

Hi,

Coveo Search API keeps failing on me. This is what i see in the log file:

4912 11:22:21 WARN  Datakey length bigger then 100 chars, and was trimmed
4912 11:22:21 WARN  Datakey length bigger then 100 chars, and was trimmed
6540 11:24:09 WARN  The connection to Coveo search service failed. The connection will be re-created. Try # 1; Error: Exception Name:FailedToImpersonateUsersException, What:There was no certificate provided by the client while trying to impersonate users. Either provide a trusted client certificate with impersonation rights or login with requested credentials.

When I restart CES and Search API service it starts working. Then randomly it stops working again. Need help.

2 Replies
Gravatar for slangevin@coveo.com

Answer by Simon, May 7, 2015 2:46 PM

Hi,

Coveo for Sitecore did not fully support TLS before February 2015. This might be the reason for the issue. What version of Coveo and Coveo fro Sitecore are you using?

Cheers,
Simon

Gravatar for puneetpande@gmail.com

Comment by ppande, May 7, 2015 3:03 PM

What exactly is it trying to do?

I think there is something weird going on. When I'm connected to VPN and using proxy, I get that issue (I think). Also, my proxy account gets locked. I guess from trying too many times.

Any insight on what might be happening?

Here's my Coveo version: 7.0 x64 Build 7256.0

Thanks!

Gravatar for slangevin@coveo.com

Comment by Simon, May 7, 2015 3:32 PM

Hard to say exactly but does it fail when you try to input a query? Your version is older than the fix, so my recommendation would be to upgrade.

The other option would be to contact Coveo support.

Cheers, Simon

Gravatar for slangevin@coveo.com

Comment by Simon, Dec 5, 2015 11:49 AM

After an investigaiton with Coveo support. The user had dlls from a Coveo for Sitecore version that was not matching several other Coveo files. Could have been a problem with the installation, fixed by installing the package a second time.

Gravatar for sdagefor@harris.com

Answer by Sean Dageforde, Aug 5, 2015 12:50 PM

For me, corrected by changing the web.config parameter for sslCertificatePath from "C:\Program Files\Coveo .NET Front-End 12\Web\cert-iis.p12" to "`C:\Program Files\Coveo .NET Front-End 12\Web\certificate.p12".

Backend: 7.0 x64 Build 7599.0

Frontend: 12.0 x64 Build 1100.0

Ask a question