Gravatar for micallahan@logmein.com

Question by mcallahan, May 28, 2015 9:52 AM

Coveo Diagnostic page error in Sitecore Control Panel

This page worked at one point, and now I get the following error on the below section of code…

Object reference not set to an instance of an object.

private void RefreshVersions()
{
    CoveoForSitecoreVersionResolver coveoForSitecoreVersionResolver = new CoveoForSitecoreVersionResolver();
    AboutWrapper aboutWrapper = new AboutWrapper();
    **this.CoveoForSitecoreVersion.Text = coveoForSitecoreVersionResolver.CoveoForSitecoreVersion.ToString();**

in Coveo.SearchProvider.Applications.CoveoDiagnosticPage class in Coveo.SearchProvider.Applications.dll

This file has not changed, \sitecore modules\Web\Coveo\Admin\CoveoDiagnosticPage.aspx.

Anyone ever have this issue, or know what could have caused it? What dependencies does the above code have that could have changed?

Gravatar for slangevin@coveo.com

Comment by Simon, May 28, 2015 9:54 AM

Is it the only thing broken? Is indexing and searching still functioning properly?

Gravatar for micallahan@logmein.com

Comment by mcallahan, Jun 2, 2015 10:43 AM

Everything else works correctly.

1 Reply
Gravatar for jflheureux@coveo.com

Answer by Jean-François L'Heureux, May 28, 2015 10:12 AM

Have you updated Coveo for Sitecore recently? We regularly add sections and improvements to this page. Maybe your Coveo DLLs and this aspx file aren't in sync to the same monthly release of Coveo for Sitecore anymore?

Gravatar for micallahan@logmein.com

Comment by mcallahan, Jun 2, 2015 10:43 AM

No I had only installed the latest version(Coveo for Sitecore 80 3.0 (1026)) This had worked at one point but it stopped working for some reason, I didn't make any modifications to it. There were processors added to pipelines, but even if i remove those I can't get this page to work.

Gravatar for micallahan@logmein.com

Comment by mcallahan, Jun 2, 2015 10:56 AM

I replaced the config files with the original configs from the Coveo for Sitecore download. I still get the error. Do you know what else could have changed that effects this?

Gravatar for jflheureux@coveo.com

Comment by Jean-François L'Heureux, Jun 2, 2015 11:02 AM

Is it possible that your Coveo for Sitecore version 80 3.0.1026 DLLs were replaced in the bin folder by a script or source control software to an older version? Can you check the DLLs properties to ensure you have the version 3.0.1026 DLLs?

Gravatar for micallahan@logmein.com

Comment by mcallahan, Jun 2, 2015 11:45 AM

Yes, that was it! I replaced them with the latest dlls, and it works correctly.

Thanks!

Ask a question