Gravatar for mohammad.chowdhury@us.tel.com

Question by mjc, Jun 9, 2015 2:49 PM

Can't access search admin

Getting "HTTP Error 503. The service is unavailable" when I try to browse Coveo Enterprise Search Admin. Could not find details about the issue. My server is running multiple application and I have tried following so far:

  • Made sure Application pool for search admin application is started
  • Restarted the Website

But these didn't not fix the issue yet. However, from even log, I found application error on ModelTagger.exe but I can run FacetAdminTool. In the front end I can access "edit this interface" in Do More but If I change something I get blank page with "Object moved to here." then page stuck on nothing.

I need to resolve this issue as soon as possible to make some changes through admin page. Any helpful suggestion please.

2 Replies
Gravatar for mohammad.chowdhury@us.tel.com

Answer by mjc, Jun 11, 2015 6:34 PM

Finally, I was able to resolve the issue. I have tried all the possible solutions to resolve this but didn't work any of them.

  • checked WAS and W3SVC
  • checked process w3wp and bound application pool
  • checked each sites status…. phew!

However, I noticed from the event log, this issue has been started after I had windows update on my server. So, I have restarted the server and all good!

Gravatar for rquirion@coveo.com

Answer by ronald, Jun 10, 2015 10:01 AM

I made a few tests on my side. The most probable reason that I see would be that the application pool would be stopped. When you say that you checked whether the "application pool for search admin application" was started, I wonder if there could be some confusion about the different applications pools. There are 2 "admin" sites in IIS:

  • Coveo Enterprise Search 7 Admin (aka the Administration Tool)
  • Coveo .NET Front-End 12 / SearchAdmin (aka the Interface Editor, this is the one for when you click Do more > Edit this interface)

Each with its distinct application pool:

  • CESAppPool admin (Administration Tool)
  • CESAppPool Front-End (Interface Editor)

What is the name of the application pool that you checked? And what is the name of the IIS web site that you restarted?

Gravatar for mohammad.chowdhury@us.tel.com

Comment by mjc, Jun 10, 2015 11:03 AM

I have checked both Application Pool and Both are started. Also, I have checked following:

  • W3SVC- started
  • CESAppPool admin (Administration Tool) - started
  • CESAppPool Front-End (Interface Editor) - started

This is what I got from http log:

  • 2015-06-09 20:52:19 ...* #### ...* #### HTTP/1.1 GET /Status/Overview/StatusOverview.aspx 503 5 N/A -
  • 2015-06-09 20:52:19 ...* #### ...* #### HTTP/1.1 GET /favicon.ico 503 5 N/A -

I am having issue with Search Admin website and this site is using application pool - CESAppPool admin

Gravatar for rquirion@coveo.com

Comment by ronald, Jun 10, 2015 12:23 PM

It's not easy to investigate remotely. Possible other reasons for a 503 error:

  • Wrong identity configured on the app pool.
  • A wrong proxy configuration.

Some 503 errors are logged in http.sys error logs (default path: %systemroot%\system32\logfiles\HTTPERR). Hopefully you'll find clues there. Otherwise, you may check on the web about how troubleshooting 503 errors. The error happens before Coveo's code is called.

Regarding the "object moved to here" error, to which page is the browser asked to redirect? If the address is not shown, using a tool like Fiddler may be helpful.

Ask a question