Gravatar for nstephens@hhogdev.com

Question by nickstephens, Jun 11, 2015 11:06 AM

Upgraded License still shows disabled web connector

We've upgraded our license and followed the upgrade instructions for Coveo for Sitecore 3. Having successfully updated the license via Sitecore, we checked the Coveo Admin tool to verify that the Web Connector is enabled. Unfortunately, the Admin configuration still shows the license as being the free edition and the web connector being disabled.

I also tried updating the license through the configuration section in the admin tool, however, the page won't accept the new license we've been given as it's for Coveo for Sitecore.

I'm not sure how to go about getting CES to recognize the new license and enable the Web connector.

1 Reply
Gravatar for jflheureux@coveo.com

Answer by Jean-François L'Heureux, Jun 11, 2015 1:38 PM

Coveo for Sitecore does not update the CES license at the time the Coveo for Sitecore license is updated. It updates the CES license before each indexing operation in Sitecore.

To ensure the CES license is updated you have to either:

  • Execute a re-index tree operation on at least 1 item of the Sitecore content tree OR
  • Rebuild a Coveo index inside Sitecore
Gravatar for nstephens@hhogdev.com

Comment by nickstephens, Jun 11, 2015 1:53 PM

Thank you! That solved it.

Ask a question