Gravatar for d.rousseau@snhu.edu

Question by drousseau99, Jul 6, 2015 5:14 PM

Coveo error on CD server with no master db

I am configuring coveo on a CD server with no master database. The queue and search api service are located on another server, and are accessible from the CD server. I am getting the following error when browsing to the search page:

Could not find add method: AddIndex (type: Coveo.SearchProvider.Configuration.CoveoSearchConfiguration) Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: Sitecore.Exceptions.RequiredObjectIsNullException: Could not find add method: AddIndex (type: Coveo.SearchProvider.Configuration.CoveoSearchConfiguration)

Source Error:

Line 11:

I have been through the tutorials on setting up Coveo across multiple servers and scaling Coveo, and Have made the configuration changes suggested in those.

Any help would be appreciated.

Gravatar for slangevin@coveo.com

Comment by Simon, Jul 6, 2015 5:25 PM

What happens when you try to load the remote REST endpoint? [Your Coveo server]:8080/rest/search ? Implying that you install the Rest API on the Coveo server and that you chose port 8080.

Gravatar for d.rousseau@snhu.edu

Comment by drousseau99, Jul 6, 2015 7:12 PM

When I browse to that url from the CD I get prompted ffor login credentials.

Gravatar for slangevin@coveo.com

Comment by Simon, Jul 7, 2015 11:56 AM

If you enter the credential used to connect to the Coveo server, you should be able to see a valid JSON. So I guess the Rest is up and running and this is not the issue.

2 Replies
Gravatar for jflheureux@coveo.com

Answer by Jean-François L'Heureux, Jul 6, 2015 5:41 PM

AddIndex is a method on the type Coveo.SearchProvider.Configuration.CoveoSearchConfiguration defined in the <configuration> node of the Coveo.SearchProvider.config file. This method takes one argument as an instance of the ISearchIndex interface. The way to define the parameter value is with the type attribute of <index> elements in the Coveo.SearchProvider.config file.

I am able to reproduce your error by removing the type attribute and value from the <index> node in my Coveo.SearchProvider.config file. Can you verify you have this type attribute please?

<index id="..." type="Coveo.SearchProvider.ProviderIndex, Coveo.SearchProvider">...</index>
Gravatar for d.rousseau@snhu.edu

Comment by drousseau99, Jul 6, 2015 7:14 PM

Yes, the type is there:

Gravatar for jflheureux@coveo.com

Comment by Jean-François L'Heureux, Jul 7, 2015 9:48 AM

Are you sure it is there for all of your indexes? You can execute the /sitecore/admin/showconfig.aspx page on your Sitecore instance to get the effective configuration. Check all the <index> elements to see if some are not configured correctly.

Gravatar for d.rousseau@snhu.edu

Comment by drousseau99, Jul 7, 2015 10:05 AM

In the showconfig.aspx, all of the coveo indexes (the ones defined in the coveo.contentsearch.config) have the correct type. There are other indexes defined elsewhere that are of a Lucene type. The Lucene types are defined in the Sitecore.Marketing.Definitions.MarketingAssets.Repositories.Lucene.IndexConfiguration.config, Sitecore.Social.Lucene.IndexConfiguration.config, and Sitecore.ListManagement.Lucene.IndexConfiguration.config files.

Gravatar for jflheureux@coveo.com

Comment by Jean-François L'Heureux, Jul 7, 2015 10:15 AM

Fine. Which version of Sitecore are you using? Also, which version of Coveo for Sitecore did you install (full file name please)?

Gravatar for d.rousseau@snhu.edu

Comment by drousseau99, Jul 7, 2015 10:21 AM

We are using Sitecore version 8. Here are the Coveo installations:

Coveo Search API 8.0.543.exe

Coveo Enterprise Search 7.0 x64 (7711) for Sitecore.exe

Coveo for Sitecore 80 3.0 (1055).zip

Gravatar for jflheureux@coveo.com

Answer by Jean-François L'Heureux, Jul 7, 2015 11:40 AM

I just read your question again and noticed your setup is a CD without a "master" DB. You could just remove the "Coveomasterindex" index node from your configuration. Did you try that?

Gravatar for d.rousseau@snhu.edu

Comment by drousseau99, Jul 7, 2015 11:41 AM

I tried that to no avail. Only the Coveowebindex was defined.

Gravatar for jflheureux@coveo.com

Comment by Jean-François L'Heureux, Jul 7, 2015 11:52 AM

Yes, "Coveowebindex" is the only index required on a Sitecore CD server. What was not working with this setup?

Ask a question