Gravatar for timsodhi@health.usf.edu

Question by timothevs, Aug 4, 2015 9:26 AM

Coveo Enterprise Search AdminService 404

We are trying to implement Coveo for Sitecore but finding it incredibly difficult to get off the ground. Either the documentation is lacking, or we are recreating the same error over and over again.

Up to our eighth full reinstall of CES on a dedicated Windows Server (2012), but we are still unable to view http://localhost/AdminService on the server. We have not secured the service, and have confirmed that the service is indeed running (via services.msc). We can access the server's admin interface to configure the index etc, so that part is working. But the localhost/AdminService returns a 404 no matter what we try.

The version of Coveo installed is 7.0 x64 Build 7711.0

3 Replies
Gravatar for timsodhi@health.usf.edu

Answer by timothevs, Aug 4, 2015 10:53 AM

Ah managed to figure it out.

The issue was a classic case of PEBKAC (Problem Exists Between Keyboard And Chair). My SysAdmin was installing CES on the server, and was putting in usernames/passwords wherever the CES installer prompted. One of the places where he entered a username/pass was while configuring the Coveo Administrative Service, which when I reread the help documentation, made me realize that by entering a password there, we were securing the AdminService.

The rest was easy. I installed a self signed cert with IIS manager, and setup a route binding for 443, and upon trying https://localhost/AdminService?wsdl it worked right off the bat.

Hope that helps someone.

Gravatar for jflheureux@coveo.com

Answer by Jean-François L'Heureux, Aug 4, 2015 9:43 AM

Is it possible that the server had already a service listening on the port 80 before installing CES and this service is handling the HTTP request?

Gravatar for jlefrancois@coveo.com

Answer by jlefrancois, Aug 4, 2015 3:00 PM

You can also find useful documentation on this page :

https://onlinehelp.coveo.com/en/ces/7.0/administrator/aboutthecoveoadminservice.htm

Ask a question