Gravatar for dennis.augustine@techguilds.com

Question by Dennis Augustine, Aug 18, 2015 11:31 AM

Could not load type 'Coveo.UI.Helpers.IFieldHelper'

We were installing Coveo on a Sitecore 7.2 instance and were getting the following error:

Could not load type 'Coveo.UI.Helpers.IFieldHelper' from assembly 'Coveo.UI, Version=3.0.0.0, Culture=neutral, PublicKeyToken=null'.

So I tried replacing the Coveo.UI.dll with one from and older version and the error went away. Unfortunately indexing failed with this error:

Job started: IndexUpdateIndexName=sitecoremasterindex|#Exception: System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> System.ServiceModel.FaultException`1[System.ServiceModel.ExceptionDetail]: Precondition failed: The parameter 'pParameterValue' must not be an empty string Parameter name: pParameterValue

Does some known issue with Coveo for Sitecore 7.2 or some potential misconfiguration immediately occur to anyone?

1 Reply
Gravatar for jflheureux@coveo.com

Answer by Jean-François L'Heureux, Aug 18, 2015 11:49 AM

Hi Dennis,

Just for verification, did you install the Coveo for Sitecore package for Sitecore 7.2 (Coveo for Sitecore 72 3.0 (XXXX).zip) or another version of the package?

For the IFieldHelper issue, this interface was moved in the Coveo.UIBase assembly but kept the Coveo.UI.Helpers namespace in the July release of Coveo for Sitecore (see Upgrading from June 2015 Release to July 2015 Release). If you had copies of Coveo's layouts or views, you should update them by following the update procedure. You should also use the package's original Coveo.UI.dll file and not a previous version of the file.

Gravatar for dennis.augustine@techguilds.com

Comment by Dennis Augustine, Aug 18, 2015 12:07 PM

Hi Jean-François,

We installed Coveo for Sitecore 7.2 3.0 (1084). We were doing this on a new Sitecore 7.2 instance that didn't have Coveo for Sitecore on it but which has a CES instance on the same box. We've tried reinstalling CES with the August release on this box and it WORKED!

We'll revert to the original Coveo.UI.dll and report back once the initial indexing is complete. Hopefully the original error doesn't reappear. I'll let you know in a few minutes.

Gravatar for dennis.augustine@techguilds.com

Comment by Dennis Augustine, Aug 18, 2015 1:13 PM

We found the issue. We have Active Commerce on this instance and it looks like that version of AC hasn't yet been updated for the August release. We're trying the July release and will pass this along to AC for a patch. I'll update again shortly.

Gravatar for jflheureux@coveo.com

Comment by Jean-François L'Heureux, Aug 18, 2015 1:16 PM

Of course, ensuring that Coveo Enterprise Search (CES), Coveo Search API and Coveo for Sitecore are on the same monthly version is essential because Coveo for Sitecore often uses new API calls from CES and the Coveo Search API modules.

Ask a question