Gravatar for sathis.k.durairaj@accenture.com

Question by Sathis, Sep 15, 2015 7:21 AM

Sitecore Connector 2 template language

I am using Sitecore connector 2 to crawl Sitecore items. When i try to crawl the item that has multiple language version, by default it takes values from English version, regardless of language parameter which i am setting in CES.

How to force the connector to take only particular language version?

Below is log message i found in log file.

Available languages of the database master are : en ; ru ; zh Default language of the database master is :

1 Reply
Gravatar for lbergeron@coveo.com

Answer by Luc Bergeron, Sep 15, 2015 8:06 AM

Hi,

There is a Languages parameter that can be set on the Sitecore source to specify which languages are indexed. By default, it indexes only english. It accepts a list of semi-colon-separated values. You can also use * to index items in all languages.

See: https://onlinehelp.coveo.com/en/ces/7.0/administrator/modifyinghiddensitecoresourceparameters.htm

Cheers

Gravatar for sathis.k.durairaj@accenture.com

Comment by Sathis, Sep 15, 2015 8:53 AM

I am also using this parameter. This is working as expected when item has single language version. If it has multiple language version, connector picks only default English version.

Gravatar for lbergeron@coveo.com

Comment by Luc Bergeron, Sep 15, 2015 9:17 AM

Sorry, I did not understand that you were already using the Languages parameter. However, the parameter works as expected for me. One thing though. The values you set on the Languages parameter must match exactly the languages that are set on the Sitecore items. Documents will be rejected from CES otherwise.

For example, if I have the en and fr-CA languages on my Sitecore items, then the Languages parameter must be set to en;fr-CA. Setting it to en;fr will not work.

As stated in the documentation, you can use * to use all languages. But you cannot do en;fr-* for example.

Ask a question