Gravatar for shirazi@rdacorp.com

Question by aga, Oct 31, 2015 1:05 AM

Unable to Index sitecore

Hi,

I just installed coveo on my Sitecore 8 CMS and after running though the coveo configuration my unable to execute an index operation. The error that is reported from the UI is:

Exception: System.NullReferenceException Message: Object reference not set to an instance of an object. Source: Sitecore.Kernel at Sitecore.Security.Authentication.FormsAuthenticationHelper.GetTicket() at Sitecore.Security.Authentication.FormsAuthenticationHelper.GetAuthenticationData(String key) at Sitecore.SecurityModel.UserRuntimeSettings.Load() at Sitecore.Security.Accounts.User.get_RuntimeSettings() at Sitecore.ExperienceExplorer.Business.Pipelines.HttpRequestProcessed.LoginVirtualUser.Process(HttpRequestArgs args) at (Object , Object[] ) at Sitecore.Pipelines.CorePipeline.Run(PipelineArgs args) at Sitecore.Nexus.Web.HttpModule. (Object , EventArgs ) at System.Web.HttpApplication.SyncEventExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute() at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)

But after looking through the logs I also found this one

8860 00:35:28 ERROR An error occurred while trying to update the user identity. It probably doesn't exist in CES yet. Exception: System.ServiceModel.FaultException`1[[System.ServiceModel.ExceptionDetail, System.ServiceModel, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089]] Message: Value does not fall within the expected range. Source: mscorlib

Server stack trace: at System.ServiceModel.Channels.ServiceChannel.ThrowIfFaultUnderstood(Message reply, MessageFault fault, String action, MessageVersion version, FaultConverter faultConverter) at System.ServiceModel.Channels.ServiceChannel.HandleReply(ProxyOperationRuntime operation, ProxyRpc& rpc) at System.ServiceModel.Channels.ServiceChannel.Call(String action, Boolean oneway, ProxyOperationRuntime operation, Object[] ins, Object[] outs, TimeSpan timeout) at System.ServiceModel.Channels.ServiceChannelProxy.InvokeService(IMethodCallMessage methodCall, ProxyOperationRuntime operation) at System.ServiceModel.Channels.ServiceChannelProxy.Invoke(IMessage message)

Exception rethrown at [0]: at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg) at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type) at Coveo.AdminService.AdminService.IAdminService.UpdateUserIdentity(CesMasterInformation pInfo, UserIdentityConfig pUserIdentityConfig) at Coveo.AdminService.AdminServiceClientWrapper.PerformAdminServiceCall(Action pAction) at Coveo.AdminService.AdminServiceClientWrapper.UpdateUserIdentity(UserIdentityConfig pUserIdentityConfig) at Coveo.AbstractLayer.Communication.CES.AdminModule.UpdateUserIdentity(String pUsername, String pPassword) at Coveo.AbstractLayer.Communication.CES.CESCommunication.UpdateUserIdentity(String pUsername, String pPassword) at Coveo.SearchProvider.ProviderIndexUserIdentityHelper.VerifyUserIdentity(IIndexPropertyStore pPropertyStore, CoveoIndexConfiguration pConfiguration)

And even this:

8860 00:35:29 ERROR CreateInstanceGeneric (Type pType, object[] pParams): Sitecore.ContentSearch.LuceneProvider.LuceneSearchFieldConfiguration failed. Exception: System.MissingMethodException Message: Constructor on type 'Sitecore.ContentSearch.LuceneProvider.LuceneSearchFieldConfiguration' not found. Source: mscorlib at System.RuntimeType.CreateInstanceImpl(BindingFlags bindingAttr, Binder binder, Object[] args, CultureInfo culture, Object[] activationAttributes, StackCrawlMark& stackMark) at System.Activator.CreateInstance(Type type, BindingFlags bindingAttr, Binder binder, Object[] args, CultureInfo culture, Object[] activationAttributes) at System.Activator.CreateInstance(Type type, Object[] args)

My CES server is remote and I've followed this guide. Also, it's worth mentioning that at first I had tried to secure the admin service but ran into issues so I re-installed CES without admin tool security and then reinstalled the same coveo for Sitecore package.

Sitecore 8.0 (rev. 150621) Coveo for Sitecore 80 3.0 (1123) Coveo Enterprise Search 7.0 x64 (7914) for Sitecore

UPDATE 1

I've gotten past the lucene exceptions and now the exception that is logged profusely is:

3248 12:55:33 ERROR An error while Initializing occurred Exception: System.NullReferenceException Message: Object reference not set to an instance of an object. Source: System.Web at System.Web.Security.FormsAuthentication.SetAuthCookie(String userName, Boolean createPersistentCookie, String strCookiePath) at Sitecore.Security.Authentication.FormsAuthenticationProvider.Login(String userName, Boolean persistent) at Coveo.Framework.Configuration.CoveoIndexConfiguration.ValidateSitecoreCredentials() at Coveo.Framework.Configuration.CoveoIndexConfiguration.Validate() at Coveo.SearchProvider.ProviderIndexBase.Initialize(IIndexDocumentPropertyMapper`1 p_DocumentTypeMapper)

I've ensured that the sitecore creds are valid in coveo configuration.

Gravatar for slangevin@coveo.com

Comment by Simon, Nov 2, 2015 4:14 PM

This stack is strange:

An error occurred while trying to update the user identity.

In the Coveo Administration Tools, I guess there are no Sources under Index>>Sources and Collections, no security provider under Configuration >> Security >> Security providers, or no user identity under Configuration >> Security User Identity, correct?

Gravatar for shirazi@rdacorp.com

Comment by aga, Nov 2, 2015 4:57 PM

Simon, I do have a source under "Index>>Sources and Collections" and the security provider is present and I also have the admin account listed under "User Identities".

Gravatar for slangevin@coveo.com

Comment by Simon, Apr 18, 2016 9:24 AM

Hi Aga, I have not responded to this one, but have you opened a ticket at support for this?

Gravatar for rizki.eka.satria@gmail.com

Comment by rizki.eka.satria, Jul 12, 2017 3:54 AM

Hi @aga,
I got exactly the same issue with this. Have you got any workaround from coveo support or probably you have solved this issue?
It is kinda frustrating to find the way to solve this.

1 Reply
Gravatar for sholmesby@hhogdev.com

Answer by sholmesby, Nov 2, 2015 2:44 PM

Your final error shows

Sitecore.ContentSearch.LuceneProvider.LuceneSearchFieldConfiguration

It looks like you either haven't disabled Lucene properly, or maybe have a custom Lucene config still hanging around.

Gravatar for slangevin@coveo.com

Comment by Simon, Nov 2, 2015 4:12 PM

Good call but this is Sitecore 8.0 . In this version, Coveo and Lucene are in Side by Side, so no need to disable the Lucene's configuration files.

Ask a question