Gravatar for cwatkins@bayleaf.com

Question by cwatkins, Dec 1, 2015 6:51 PM

Sometimes all Facets disappear - Coveo Sitecore

We've noticed with Coveo for Sitecore, depending on if we're adding a computed field, or during certain search setting changes, that it causes all of the facet values and facets to disappear completely. Ie. the left hand column where the mvc facets show are empty.

What's the best way to debug this issue?

I thought we used to see "field configuration mismatch" errors in the logs before when this would happen, but this time I don't see any errors. The only closely related error I can see in the sitecore logs are:

43212 15:49:30 WARN  The standard values field of template /sitecore/templates/CoveoModule/Search/Coveo Search Parameters:{5E0C9885-2582-44D0-8296-A90845181835} does not contain an ID that points to a child
43212 15:49:30 WARN  The query node type 'Custom' is not supported in this context.

Any thoughts? Would it help to turn on coveo search view client debugging to see what comes back from the REST service?

Gravatar for mlaporte@coveo.com

Comment by Martin Laporte, Dec 2, 2015 2:48 AM

This would help yes. Or a network trace made using Fiddler, since those are very easy to make and package.

1 Reply
Gravatar for jflheureux@coveo.com

Answer by Jean-François L'Heureux, Dec 2, 2015 9:30 AM

The warning "The standard values field of template /sitecore/templates/CoveoModule/Search/Coveo Search Parameters:{5E0C9885-2582-44D0-8296-A90845181835} does not contain an ID that points to a child" means that your Coveo Search Parameters item __Standard Values subitem cannot be found.

This __Standard Values item is included in the Coveo for Sitecore package by default. Maybe someone on your team accidentally deleted the item.

You should reinstall the Coveo for Sitecore package to fix this issue by overriding all the items when asked by Sitecore at installation.

For the "The query node type 'Custom' is not supported in this context." warning, you can ignore it. This is a message displayed when Coveo for Sitecore handles LINQ queries but the queries still work correctly.

Gravatar for dsoriano@littelfuse.com

Comment by Dean, Mar 14, 2016 8:38 PM

@jflheureux "For the "The query node type 'Custom' is not supported in this context." warning, you can ignore it. This is a message displayed when Coveo for Sitecore handles LINQ queries but the queries still work correctly." Can we suppress this message in our Sitecore logs? we'd like to save some processing in the background and we got tons of these in our live site. Thanks

Gravatar for jflheureux@coveo.com

Comment by Jean-François L'Heureux, Mar 16, 2016 5:42 PM

@dsoriano, I think configuring a custom Log4Net logger and appender to separate the logs from the class logging them in a separate file and setting the log level for this one to ERROR instead of WARN or INFO would do the trick.

Ask a question