Gravatar for nick.daigle@rbaconsulting.com

Question by Nick Daigle, Dec 16, 2015 11:46 AM

CES Fails to install .NET 3.5 SP1 when it's already installed.

I've been trying to run the installation of CES and can't get past the prerequisites. It's saying I do not have .NET 3.5 SP1 installed, but looking at the registry it definitely is. Looking at HKLM/SOFTWARE/Microsoft/NET Framework Setup/NDP/v3.5 I see Version = 3.5.30729.4926 and SP = 1.

I'm assuming it's failing to install it because it's already there. Is there any way to get past this? What is the exact version it's actually looking for?

Edit:

Forgot to mention this is on Windows 10 with the CES 7.0 x64 (8047) installer.

1 Reply
Gravatar for dblanchette@coveo.com

Answer by dblanchette, Dec 16, 2015 5:20 PM

You are checking the right registry key.

An issue we sometimes have is that the system was not rebooted following installation of .NET 4.5.2, so you might want to try rebooting your system.

Otherwise, I suggest checking the bootstrapper logs. Bootstrapper logs are created in %TMP%, in a subdirectory named VS*.tmp, the log file is called install.log. Example : "C:\Users\dblanchette\AppData\Local\Temp\VSDCEB9.tmp\install.log".

The program that is run to check whether .NET 3.5 SP1 is installed, Coveo.CES.CheckNET35SP1Installed.exe, is also in a subdirectory of the VS*.tmp directory called CheckNET35SP1Installed. You can try running it, a 0 exit code means .NET 3.5 SP1 is installed.

Gravatar for nick.daigle@rbaconsulting.com

Comment by Nick Daigle, Dec 16, 2015 5:35 PM

.NET 4.6.1 was previously installed and I've done system reboots between retries.

Checking the logs I see CheckNet35SP1Installed.exe is incorrectly returning 1. I have tried removing and then enabling .net 3.5 again. No luck there.

Gravatar for dblanchette@coveo.com

Comment by dblanchette, Dec 16, 2015 5:51 PM

Looking at the code, I see that it is looking for a subkey of the v3.5 key. In my case, there is a subkey 1033 with Version = 3.5.30729.4926 and SP = 1. You might also want to check Wow6432Node, e.g. HKLM/SOFTWARE/Wow6432Node/Microsoft/NET Framework Setup/NDP/v3.5.

In case Coveo.CES.CheckNET35SP1Installed.exe returns 1, the command that is run is pkgmgr.exe /iu:NetFx3.

Gravatar for nick.daigle@rbaconsulting.com

Comment by Nick Daigle, Dec 17, 2015 3:20 PM

The problem was the subkey was missing for my install of .net 3.5. I added 1033 with the same values as the parent key. Everything worked after adding that.

Gravatar for dipsindol@gmail.com

Comment by DEEPTHI KATTA, Aug 5, 2016 5:42 PM

Ok, So is Coveo going to fix this issue on Windows 10? Is meddling with registry values only way? If then, is there documentation with screenshots on how to make this work? I am currently stuck at the same situation and hesitant to make registry changes to make CES installation work.

Gravatar for dipsindol@gmail.com

Comment by DEEPTHI KATTA, Aug 5, 2016 6:08 PM

I did this steps and it worked. I wish Coveo can come up with fix or checking the actual key instead of subkey of 3.5, should be fairly simple. They can do either the actual item or subkey with code 1033. Anyway, I was able to move forward

Gravatar for dblanchette@coveo.com

Comment by dblanchette, Aug 8, 2016 11:31 AM

Thanks for your feedback Dipsindol. An issue is opened on our side and we will look into it.

Gravatar for dblanchette@coveo.com

Comment by dblanchette, Aug 17, 2016 9:20 AM

A fix for this problem will be delivered with the September 2016 build of CES.

Ask a question