Gravatar for dsoriano@littelfuse.com

Question by Dean, Dec 29, 2015 7:28 PM

Issue with Internet Explorer 11 - Keyword gets cleared on redirect

Hi,

We are currently having an issue whenever we redirect (from a 404 page) to a Coveo search page (our search page has some input boxes with button and on click we just take the value of the input and append it to the search page link ex: some coveo page url#q=search term )

This redirects to the coveo page but the problem is the breadcrumb with keyword gets cleared for whatever reason although the search seem to have returned the filtered results (based from the keyword).

The search page url shows only this: some coveo page url#, notice the q=keyword is now gone.

Thanks

1 Reply
Gravatar for jflheureux@coveo.com

Answer by Jean-François L'Heureux, Dec 30, 2015 1:57 PM

If your search page doesn't have a CoveoSearchBox in its DOM, it may be the cause of your issue. The CoveoSearchBox is responsible to read and maintain the q state attribute and value.

You may also have custom JavaScript that plays with the page URL hash and removes it. You should inspect all the JavaScript code loaded in the page in the browser developer tools.

I hope this helps.

Jeff

Gravatar for dsoriano@littelfuse.com

Comment by Dean, Dec 31, 2015 7:06 PM

Hi Jeff,

But why would the behavior only happen in IE 11? Other browsers seem to redirect fine. I'll check the scripts again, but on initial checking i didn't find anything relevant

Thanks

Ask a question