Gravatar for anweshadastider@gmail.com

Question by anwesha, Apr 21, 2016 5:33 AM

"Required license is missing: Runtime" error in Coveo for Sitecore

I have installed Coveo in Sitecore 8.1. Everything shows up and running in the coveo diagnostic page, all coveo services are running, documents are successfully indexed. But when I created a Coveo Search Page (tried with both MVC and WebForm search page), its throwing a "Required license is missing: Runtime" error while browsing. Please see below screenshot of the error.

Current Coveo for Sitecore version: 3.0.1266.0

Current Sitecore version: 8.1.151207

alt text

Gravatar for slangevin@coveo.com

Comment by Simon, Apr 21, 2016 9:13 AM

I do not believe this is related to Coveo even if the error is while loading one of our rendering. The error clearly shows a license limitation in regards to the xDB.

Have you upgraded to 8.1 recently? Do you have a limitation in your license in regards to the xDB?

Gravatar for anweshadastider@gmail.com

Comment by anwesha, Apr 22, 2016 12:03 AM

Yes I have upgraded to Sitecore 8.1. You are right. It is related to Sitecore 8.1 licensing limitations. Temporarily fixed it by disabling the analytics. Thanks!!!

1 Reply
Gravatar for jflheureux@coveo.com

Answer by Jean-François L'Heureux, Apr 21, 2016 10:27 AM

Sitecore 8.1 requires a new Sitecore license as Sitecore has changed the xDB licensing. You cannot use a Sitecore 7.x/8.0 license with Sitecore 8.1.

Gravatar for anweshadastider@gmail.com

Comment by anwesha, Apr 22, 2016 12:04 AM

Thanks for the information! This is the exact reason for the above error.

Ask a question