Gravatar for dsoriano@littelfuse.com

Question by Dean, Apr 21, 2016 7:43 PM

Multiple versions Indexed in Coveo_Web_Index

HI,

I noticed something odd, in our Coveo for sitecore instance, I'm seeing multiple versions indexed in our Coveo web index. Example, we have v7 and v8 for the same item in our web index. When I checked our web Db, as expected, the web only has the latest which is v8. Any ideas?

Thanks

2 Replies
Gravatar for dsoriano@littelfuse.com

Answer by Dean, Aug 16, 2016 9:03 AM

Just an update, after another round of full reindex. The duplicates have disappeared.

Gravatar for sbelzile@coveo.com

Answer by Sébastien Belzile, Apr 22, 2016 8:00 AM

What is your Sitecore version? I think this is your problem: https://answers.coveo.com/questions/5587/_latestversion-virtualfield-showing-1-for-all-items

Gravatar for dsoriano@littelfuse.com

Comment by Dean, Apr 22, 2016 10:11 AM

we are using 7.0, looks like the one in the link is 7.2

Gravatar for sbelzile@coveo.com

Comment by Sébastien Belzile, Apr 22, 2016 10:19 AM

7.0 which update? Which version of C4SC do you use? I would like to try this on my side.

Gravatar for dsoriano@littelfuse.com

Comment by Dean, Apr 22, 2016 12:09 PM

7.0 Update 4, we use the Aug 2015 version of C4SC

Gravatar for sbelzile@coveo.com

Comment by Sébastien Belzile, Apr 25, 2016 8:37 AM

Works fine on my side. Do you have anything special in your configuration that could prevent these items from being removed? Ex: an inbound filter? something in the coveoItemProcessingPipeline or in the coveoPostItemProcessingPipeline?

A rebuild does fix the problem?

Gravatar for dsoriano@littelfuse.com

Comment by Dean, May 23, 2016 4:52 AM

@sbelzile - unfortunately a rebuild doesn't remove the old version. Yes we do have some processors in those pipelines but nothing related to the given items in question.

I did find out one difference between the two versions. The latest (v8) has one more field than the old one (v7). This is a new field we added recently. Would this cause the old version to not get deleted upon publish in the web_index of Coveo?

On another note, can we force delete an indexed document in Coveo?

Thanks

Gravatar for sbelzile@coveo.com

Comment by Sébastien Belzile, May 24, 2016 8:27 AM

What is the modified date of the two documents? How do these dates compare to the date of your latest rebuild?

Usually when clients report this kind of problem, the link I posted solves their issue. Since your Sitecore version is not affected by this bug, since I cannot reproduce the issue and if you cannot tell us the workflow that creates your issue, I think you should open a support case.

I don't think force deleting a document in Coveo would solve your problem. It would solve it temporarily, but the problem will eventually come back.

Gravatar for dsoriano@littelfuse.com

Comment by Dean, Jun 8, 2016 10:58 AM

@sbelzile - The modified dates were about a month apart (please see image) https://answers.coveo.com/upfiles/multipleversionsinweb.png

Gravatar for sbelzile@coveo.com

Comment by Sébastien Belzile, Jun 8, 2016 11:10 AM

I think this is support case material. You should open a support case. Add a link to this question when opening the case, along with as any source of data that could be useful, ex: showconfig.

Gravatar for dsoriano@littelfuse.com

Comment by Dean, Aug 16, 2016 9:03 AM

Just an update, after another round of full reindex. The duplicates have disappeared.

Ask a question