Gravatar for richard.stokes@medica.com

Question by mnrichardstokes, May 5, 2016 1:05 PM

Omnibox Autocomplete asks for WIndows Authentication randomally

I have a omnibox autocomplete that sometimes popups the Windows Authentication popup. When I try to enter my credentials it still fails. It only happens in IE and to get it to replicate it I have to keep IE open for many minutes and try to type something in. I only need anonymous authentication for the searches. All the searches work just fine, just the autocomplete fails.

My config.yml looks like

basicAuthentication:
  enabled: false
  provider: Active Directory

windowsAuthentication:
  enabled: true
  provider: Active Directory

guest:
  enabled: true
  name: S-1-1-0
  provider: Active Directory
  type: Group

The error message i get in the Search API log is

09:21:04.360 [qtp266272063-77] DEBUG c.c.s.a.i.SearchSessionFactory - Creating new local session with key: https://pwive-intsrch01.corp.medica.com:52810#V7-false@UserId(CORP\FirstName.LastName,Sitecore Security Provider,User,None,None)!sortCriteria:occurrences,pattern:*Appointme*,field:@titlecomputed,errorsAsSuccess:1,patternType:Wildcards,maximumNumberOfValues:10,ignoreAccents:true,siteName:website,sitecoreItemUri:sitecore://web/{CE5B6A04-481E-43C0-88CE-53ACD78CF3FC}?lang=en&ver=1,queryOverride:

09:21:04.435 [qtp266272063-76] DEBUG c.c.s.api.rest.LocalSearchServlet - Bad credentials
com.coveo.search.api.rest.BadCredentialsException: Bad credentials
    at com.coveo.search.api.rest.authentication.WindowsAuthenticationProvider.processChallenge(WindowsAuthenticationProvider.scala:78) ~[coveo-search-api-server.jar:na]

Did I configure something wrong? Did I miss something in IIS?

Gravatar for richard.stokes@medica.com

Comment by mnrichardstokes, May 5, 2016 1:39 PM

A little more info.

Using Sitecore 8.1 Update 2 This is for an Intranet so we are using the AD Module Using March 2016 release of Coveo and Coveo Search API We use IE 11

1 Reply
Gravatar for mlaporte@coveo.com

Answer by Martin Laporte, May 6, 2016 4:55 AM

Hmm that's weird, I don't remember ever encountering something like this.

One thing to try: in windowsAuthentication section, add an entry like this one:

protocols: ["NTLM"]

This will for it to use NTLM instead of Kerberos. I'm curious to see if this helps.

Otherwise, if you don't need authentication at all for searches, you might also simply disable Windows Authentication altogether…

Gravatar for richard.stokes@medica.com

Comment by mnrichardstokes, May 12, 2016 7:44 PM

That did the trick. Thanks for the assistance.

Ask a question