Gravatar for chris.weiss@rbaconsulting.com

Question by chrisweiss, Aug 3, 2016 4:23 PM

Coveo Facet Date Slider View Errors

(I'm using Coveo for Sitecore 4.0, June release, with Sitecore 8.1 Update 2)

I have a search view on a page with sever facet views that are working correctly. They're all normal facet views based on string values. But I've been trying to add a couple Facet Date Slider Views in Experience Editor and am getting the following errors:

  1. The facet name must be set.
  2. Slider minimum must be lower than slider maximum.

The problem is that these errors make no sense. I have set the facet name and was able to pick the correct facet in the facet field drop down. I've also tried multiple ways of setting the minimum and maximum dates for the slider.

I've also checked the field definitions in the CES admin tool and it is set as a facet of the right datatype (Date/time) as well as holding the correct values.

Any ideas on why this might be happening?

Thanks!

1 Reply
Gravatar for sbelzile@coveo.com

Answer by Sébastien Belzile, Aug 4, 2016 8:14 AM

Hi Chris,

This bug has been fixed with the June release.

  1. Are you sure that you are using the June release?
  2. The bug was that C4SC was using the wrong field format (Sitecore VS Coveo formats) to resolve the field type. What is the format of your field?
  3. Do you have another field having the same name as your field but with a different type?
  4. How is your field declared? Is it a real field on a Sitecore template? or something you added in your configuration?
  5. Have you tried with another field of the same type?
Gravatar for jflheureux@coveo.com

Comment by Jean-François L'Heureux, Aug 4, 2016 9:20 AM

Also, if you upgraded to the June 2016 release, have you rebuilt your indexes since?

Gravatar for chris.weiss@rbaconsulting.com

Comment by chrisweiss, Aug 4, 2016 2:31 PM

  1. Yep, I'm sure we're using the June release. We've been using it for about a month. We've definitely been reindexing during that time.
  2. I've tried a couple different types (string and Date/time). Currently, it's set to Date/time in the Coveo index.
  3. There are two fields with similar names. For example, Effective Date and effective_date. However, we have several instances of string-based facets that work properly despite having names similar like this.
  4. I've tried just marking the fieldType as a facet. Currently, I'm using a ComputedField class to make sure the right value is being given. The CES admin tool also shows the correct value is in the index.
  5. We're currently trying to set this up with two date fields, but neither one is working.
Gravatar for sbelzile@coveo.com

Comment by Sébastien Belzile, Aug 4, 2016 2:36 PM

Question 2: Sorry, maybe I was not clear enough, by format, I meant the field name format (pineapple vs fpineapple12345).

Question 4: you did not answered the question: is the field a computed field or a normal field declared on a Sitecore template, or else?

Gravatar for chris.weiss@rbaconsulting.com

Comment by chrisweiss, Aug 4, 2016 2:52 PM

Thanks for helping out!

  1. Here's the field name in the index feffectivez95xdate44885 for effective_date. It's marked for Field Queries, Facet, Sort, and Display Field. Let me know if that's what you're looking for.
  2. I've tried both as just a normal field (on the Effective Date field, which is just a string) and well as a Computed Field (effective_date).
Gravatar for sbelzile@coveo.com

Comment by Sébastien Belzile, Aug 4, 2016 3:34 PM

I just tried it on my side. Worked as expected. I'm clueless about what might be going on and I think you have support case material.

The next thing I would try would be to compare your dlls. As I mentionned, this bug was fixed in build 222 (June), this means I suspect a wrong version number or a missed step during an update.

Please include the diagnostic package when opening the support case.

Gravatar for chris.weiss@rbaconsulting.com

Comment by chrisweiss, Aug 5, 2016 4:10 PM

Thanks, I'll give that a shot!

Ask a question