Gravatar for naveen.simhadri467@gmail.com

Question by naveen, Oct 3, 2016 11:25 AM

Disabling Usage analytics in coveo for sitecore

We have placed our servers in more secured space in our infrastructure we don't have outbound access to platform.cloud.coveo.com. Eventually coveo is failing to get license details and search token. Is there any way we can use coveo without making calls to platform.cloud.coveo.com? I am wondering why we have to pull license from cloud as we have already license.xml file?

Gravatar for gminero@coveo.com

Comment by gminero, Oct 4, 2016 9:48 PM

what coveo for sitecore version do you have?

1 Reply
Gravatar for jflheureux@coveo.com

Answer by Jean-François L'Heureux, Oct 5, 2016 10:09 AM

I assume you are using Coveo for Sitecore 4.0.

The coveolicense.xml file is maintained by the process that gets the Coveo for Sitecore license from platform.cloud.coveo.com to keep a local copy.

Having no access to platform.cloud.coveo.com means your Sitecore instance will be unable to fetch the license, unable to send queries to a Coveo Cloud index, and unable to send Coveo Usage Analytics to Coveo Cloud. You should really add a firewall rule to allow outbound connection: https://onlinehelp.coveo.com/en/cloud/coveocloudv1platformipaddressesto_whitelist.htm

If that is not possible, Coveo Usage Analytics can be disabled on the Coveo Search component options by unchecking "Enable Coveo Usage Analytics": https://developers.coveo.com/display/SitecoreV4/Configuring+the+Analytics+Component

Gravatar for naveen.simhadri467@gmail.com

Comment by naveen, Oct 6, 2016 11:40 AM

Thanks for the input. I could disable usage analytics in component options and license issue fixed now by copying encryption keys and coveolicense.xml. After that my site is taking 42 secs to get coveo results. So, I decided to enable trace information, I am seeing a weird logs , it seems to me xx01234567-0123-4567-8901-abcdefabcdef and org=sitecorepinghome was hardcoded some where as I am not seeing anything in my configuration. I don't understand why we need the below calls from server. As we don't have outbound firewall open these calls are blocking. and out of my surprise in logs it is aying Async but I bet it is not because I am seeing the same sequence order of execution for all requests. Any I idea how can I disable it?

7332 10:21:37 TRACE Entering LogCustomEvent
7332 10:21:37 DEBUG Calling Async POST 'https://platform.cloud.coveo.com/rest/ua/v15/analytics/custom?org=sitecorepinghome' (API calls: 1).
7332 10:21:37 DEBUG Request Headers:
7332 10:21:37 DEBUG Content-Type: application/json
7332 10:21:37 DEBUG Authorization: Bearer xx01234567-0123-4567-8901-abcdefabcdef
7332 10:21:37 DEBUG Host: platform.cloud.coveo.com
7332 10:21:37 DEBUG Begin Async request to https://platform.cloud.coveo.com/rest/ua/v15/analytics/custom?org=sitecorepinghome.
7332 10:21:37 DEBUG End Async request.
7332 10:21:37 TRACE Exiting LogCustomEvent
Gravatar for jflheureux@coveo.com

Comment by Jean-François L'Heureux, Oct 6, 2016 3:08 PM

sitecorepinghome is the Coveo Cloud organization Coveo uses to keep customers usage of Coveo for Sitecore. By accepting the EULA, you accepted to have basic statistics on your Sitecore+Coveo sent to Coveo this way. The logging occurs once in a while when the connection is allowed. Since you block the connection at the firewall level, I bet Coveo for Sitecore tries to send them at each request. As we see in the logs, it should be async.

I encourage you to open a support ticket to troubleshoot your query duration issue.

I also encourage you to create a firewall rule to allow outbound connections to Coveo Cloud: https://onlinehelp.coveo.com/en/cloud/coveocloudv1platformipaddressesto_whitelist.htm

Ask a question