Gravatar for yves.bordeleau@giro.ca

Question by yves, Nov 7, 2016 5:23 PM

Error: Coveo Front-end SSO Configuration page not found

Hi,

Trying to configure the CLAIMS SSO for SharePoint 2010. Getting Error 404 accessing the setup page :

Requested URL: /_layouts/COVEO/ClaimsIdentityProviderSetup.aspx

Coveo search is working when used within a SharePoint Site, but no results when searching from the Coveo front end - outside SharePoint.

1 Reply
Gravatar for rquirion@coveo.com

Answer by ronald, Nov 8, 2016 9:36 AM

Hi Yves,

First, is your SP 2010 web app configured with claims authentication? If it's rather configured with "simple" Windows authentication, configuring the claims SSO may not be needed.

Assuming that the claims SSO is needed, as mentioned on this online help page, the address of the setup page is https://SharePointFrontEndServer/layouts/CES/ClaimsIdentityProviderSetup.aspx (your address contains "COVEO" after "layouts" instead of "CES").

If with the right address you still get the 404 (not found) error, may it be that you did not select the "SharePoint Web Service" feature when installing the Coveo .NET Front-End?

Regards.

Gravatar for yves.bordeleau@giro.ca

Comment by yves, Nov 9, 2016 3:05 PM

Hi Ronald,

You're right - wrong address, has i've been trying to get around the error. Have same error with CES in URL. Yes, Claims authentication is specified in SP Central Admin.

Gravatar for jflheureux@coveo.com

Comment by Jean-François L'Heureux, Nov 9, 2016 5:06 PM

Is this issue resolved? If so, can you mark Ronald's answer as accepted please?

Thanks

Gravatar for rquirion@coveo.com

Comment by ronald, Nov 9, 2016 5:23 PM

Hi Yves, If your problem is still present with the right URL:

  1. Are you using a recent build of the Coveo .NET Front-End on both the Coveo Front-End and SharePoint servers? You must use at least June 2016, and ideally September 2016.
  2. Is your SP webapp/site accessible on the default HTTP port i.e. 80? If not, make sure to specify its address correctly at the beginning of the URL e.g. http://SharePointServer:12345/subpath/_layouts/CES/ClaimsIdentityProviderSetup.aspx
  3. On the SharePoint server, you could open IIS Manager and check if the virtual directories "_layouts/CES" are present in your SharePoint site. If you selected the "SharePoint Web Service" feature while installing Coveo .NET Front-End, they should be present.
Gravatar for yves.bordeleau@giro.ca

Comment by yves, Nov 10, 2016 11:38 AM

Hi Ronald,

  1. We are running Build 8047.3 - December 2015…
  2. port :80 - working ok
  3. Virtual directory : ok.

We will use the Manual SSO config, as mentioned in the instructions!

Thx,

Yves

Ask a question