Gravatar for swamcts@gmail.com

Question by swamcts, Nov 13, 2016 6:08 PM

Need Connection String for SQL Server Database with database connector

I am using coveo for sitecore, CES7.

We have the enterprise licence, and we are trying to index SQL server database using coveo OOTB database connector. https://onlinehelp.coveo.com/en/ces/7.0/administrator/database_connector.htm

Here we need to use one parameter for the connection string. Just want to confirm the connection string for "SQL Server" I tried this, not working.

Driver={SQL Server};Server=myServerAddress;Database=myDataBase;Uid=myUsername; Pwd=myPassword;

Is this correct? Please tell me the correct format.

Thanks Swami

Gravatar for jflheureux@coveo.com

Comment by Jean-François L'Heureux, Nov 14, 2016 8:27 AM

Hi Swami, I don't know which database you are referring to. This website is not a place where to get general help. It is only for Coveo products questions.

Thanks,

Jeff

Gravatar for swamcts@gmail.com

Comment by swamcts, Nov 14, 2016 9:37 AM

Hi Jeff,

Sorry for not mentioning clearly.

Am using coveo for sitecore, CES7.

In CES7 we got enterprise licence , and we are trying to index SQL server database using coveo OOTB database connector. https://onlinehelp.coveo.com/en/ces/7.0/administrator/database_connector.htm

Here we need to use one parameter for connection string, just want to confirm the connection string for "SQL Server" I tried this, not working. Driver={SQL Server};Server=myServerAddress;Database=myDataBase;Uid=myUsername; Pwd=myPassword;

is correct? Please tell the correct one.

Thanks Swami

Gravatar for jflheureux@coveo.com

Comment by Jean-François L'Heureux, Nov 14, 2016 10:04 AM

Thanks for your details. I updated your question and re-opened it.

2 Replies
Gravatar for swamcts@gmail.com

Answer by swamcts, Nov 15, 2016 10:24 AM

Working now, for the server i opened firewall between CES and DB it resolve the issue. Thanks all.

Gravatar for ldblanchet@coveo.com

Answer by ldblanchet, Nov 14, 2016 10:12 AM

Which parameter are you trying to replace?

This page shows you own to perform the replacement for the user identity : https://onlinehelp.coveo.com/en/ces/7.0/administrator/replacingtheidentityinconnection_strings.htm

Gravatar for swamcts@gmail.com

Comment by swamcts, Nov 14, 2016 10:51 AM

Am trying to configure database source using below link,

https://onlinehelp.coveo.com/en/ces/7.0/administrator/configuringandindexingadatabase_source.htm

here for "Address" parameter i need to mention connection string for "SQL Server". Which will used to conenct to database for indexing. Using this link https://www.connectionstrings.com/, i tried Driver={SQL Server};Server=myServerAddress;Database=myDataBase;Uid=myUsername; Pwd=myPassword; but not working.

So please tell connection string for SQL server?

Gravatar for jflheureux@coveo.com

Comment by Jean-François L'Heureux, Nov 14, 2016 11:05 AM

Swami, please answer @ldblanchet question. Which parameter, inside the connection string, is not working in your case?

  • {SQL Server}
  • myServerAddress
  • myDataBase
  • myUsername
  • myPassword

You probably know that you need to replace all those tokens by your own values, right?

Thanks

Jeff

Gravatar for ldblanchet@coveo.com

Comment by ldblanchet, Nov 14, 2016 11:09 AM

Also, you can use placeholders to use the user identity just like specified in the link https://onlinehelp.coveo.com/en/ces/7.0/administrator/replacingtheidentityinconnection_strings.htm which I referenced above.

Gravatar for swamcts@gmail.com

Comment by swamcts, Nov 14, 2016 12:29 PM

Driver={SQL Server};Server=myServerAddress;Database=myDataBase;Uid=myUsername; Pwd=myPassword; but not working Am getting this error: Unable to execute query with connection string : ERROR [IM002] [Microsoft][ODBC Driver Manager] Data source name not found and no default driver specifie

Ask a question