Gravatar for dipsindol@gmail.com

Question by DEEPTHI KATTA, Nov 18, 2016 8:03 PM

Adding a new Item does get indexed

When I add a new item on content tree, it does not seem to appear on index on both master and web. Even after publish, I see the item on web database, but, I do not see this item on Index and neither on search results until I rebuild my index. I am using OOTB configuration for Index Update strategies which should typically be SyncMaster and Publish End Sync. FYI, when I update an existing item with a new field value for example, everything works great the changed value shows up on Index and listing fine. We obviously want to resolve this problem as content authors would not want to rebuild their index every time they add a new item

Gravatar for vlambert@coveo.com

Comment by vince, Nov 19, 2016 12:09 PM

Have you validated that you still have the syncMaster on the Coveomasterindex using the showconfig.aspx? There may be a patch file removing it afterward. Also, what are the version of Sitecore and Coveo for Sitecore of your setup?

Gravatar for dipsindol@gmail.com

Comment by DEEPTHI KATTA, Nov 19, 2016 12:54 PM

Yes, I have validated on show config that coveo master has 'coveoSyncMaster' and Web has 'coveoOnPublishEndAsync'. But, both of these indexes are not getting updated on publish for newly created items(On publish as well same is the case). And both work well for just update of fields say on existing items. Is there anything else I would need to check? Sitecore version is 8.1, update 2 Coveo version is October release of all components(we are on latest version)

Gravatar for dipsindol@gmail.com

Comment by DEEPTHI KATTA, Nov 19, 2016 1:36 PM

On my local, I went to CES console and turned off and turned on 'Live Monitoring' on indexes of my choice. It seems after I did that it started working. Is this a step that we would need to do after a fresh Coveo install for this to function per expectation?

1 Reply
Gravatar for vlambert@coveo.com

Answer by vince, Nov 24, 2016 9:50 AM

Something is still strange in the behavior you are describing, because if turning off and on the Live Indexing solved the issue, the Rebuild of the index should not have worked either.

Regardless, when using multiple Sitecore instances on a single Coveo Enterprise Search server, you may reach a point where the number of Sitecore sources exceeds the pre-configured amount of concurrent indexing connectors. This will result in various indexing issues, for instance some items not getting indexed. Manually toggling the Live Indexing will reactivate the connector momentarily, but other sources may still be impacted.

Coveo has an article to explain and solve the given case the right way: https://support.coveo.com/s/article/Coveo-for-Sitecore-indexes-refuses-to-get-created-in-a-Sitecore-multi-site-setup

Gravatar for dipsindol@gmail.com

Comment by DEEPTHI KATTA, Nov 30, 2016 7:31 PM

Thank you on this piece of info. I am using free version on my local. We use Pro on our servers, so I am assuming that will have upper limit on number of concurrent indexing connectors. If we encounter this again, we will take a deeper look. For now our environments look okay. This was more of a problem locally.

Ask a question