Gravatar for swamcts@gmail.com

Question by swamcts, Dec 1, 2016 1:11 PM

Error in CoveoDiagnosticPage after installation

Hi,

Am getting below error, please help me.

Current Coveo for Sitecore version: 4.0.450.0
Current Sitecore version: 7.2.140526
Compatibility status: these versions are compatible

Coveo Search REST Endpoint    
The remote server returned an error: (401) Unauthorized.

Coveo Search Web Service    
Invalid URI: The format of the URI could not be determined.  Search for information on search.coveo.com
Show details

Coveo Security Provider    
Up and running

Coveo Security Service    
The remote server returned an error: (401) Unauthorized.  Search for information on search.coveo.com

Note:

  • https://Sitecorehostname/sitecore/Coveo/rest - working
  • http://CEShostname:8080/rest/search - working.
  • from CES sever able to ping/access https://Sitecorehostname.

Still am facing issue.

Thanks Swami

1 Reply
Gravatar for sbelzile@coveo.com

Answer by Sébastien Belzile, Dec 1, 2016 1:59 PM

The "Coveo Security Service" test is looking at the Sitecore web service (the service CES uses to retrieve securities). It uses the credentials you entered in the post installation wizard. I think you may have done a typo in your username or password => that would explain the 401s.

To edit your credentials, follow the instructions here.

The "Invalid URI: The format of the URI could not be determined" error: I would like to see the "coveo/restEndpointConfiguration" node from your show config.

Gravatar for swamcts@gmail.com

Comment by swamcts, Dec 1, 2016 2:25 PM

hI,

Thanks for the respnse.

I have updated the credentials again, but still same issue.

Gravatar for sbelzile@coveo.com

Comment by Sébastien Belzile, Dec 1, 2016 2:27 PM

=> The "Invalid URI: The format of the URI could not be determined" error: I would like to see the "coveo/restEndpointConfiguration" node from your show config.

Gravatar for swamcts@gmail.com

Comment by swamcts, Dec 1, 2016 2:38 PM

How to see that? in showconfig i didnt get any error.

https://sitecorehostname/sitecore/admin/showconfig.aspx

While indexing am getting the below

Job started: Index_Update_IndexName=Coveo_TC8_TagTest|#Exception: System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> Coveo.AbstractLayer.Exceptions.StopRebuildException: An error occurred while querying indexed documents. ---> System.UriFormatException: Invalid URI: The format of the URI could not be determined.
Gravatar for sbelzile@coveo.com

Comment by Sébastien Belzile, Dec 1, 2016 2:50 PM

How to see that? in showconfig i didnt get any error. => of course. The showconfig.aspx page shows you the resulting Sitecore configuration generated by all your config files. What I'm asking for, is the content of one of the nodes rendered on the page: restEndpointConfiguration, located under the coveo node.

Gravatar for swamcts@gmail.com

Comment by swamcts, Dec 1, 2016 3:02 PM

Config:

<restEndpointConfiguration type="Coveo.Framework.Configuration.RestEndpointConfiguration, Coveo.Framework" patch:source="Coveo.SearchProvider.Rest.config">
<!--
     The secret key must be configured in the search api service as well. This way, the search api service can trust the application. 
-->
<applicationSecret>qZe3yAALvvlN76cqjBmCcN5AWBq7dVkcvNwXOo1UEqtReLfWbMlVtKQM6Of7kEIKljstJpM5KC9WunvlwD5BJySU7U3ai4K0RSF5</applicationSecret>
<!--
     The timeout period for requests going through the search api proxy.
-->
<requestTimeout>00:00:30</requestTimeout>
<!--
     Defines the location of the REST endpoint in the website. 
-->
<restEndpointPath>/coveo/rest</restEndpointPath>
<!--  The period during which the search token is valid.  -->
<searchTokenExpiration>01:00:00</searchTokenExpiration>
<!--  The URI to connect to the search api service.  -->
<searchApiUri>http://cessevername:8080/</searchApiUri>
<apiKey ref="coveo/cloudPlatformConfiguration/apiKey" patch:source="Coveo.SearchProvider.Rest.Custom.config"/>
<organizationId ref="coveo/cloudPlatformConfiguration/organizationId" patch:source="Coveo.SearchProvider.Rest.Custom.config"/>
<analyticsUri patch:source="Coveo.SearchProvider.Rest.Custom.config">https://usageanalytics.coveo.com</analyticsUri>
</restEndpointConfiguration
Gravatar for sbelzile@coveo.com

Comment by Sébastien Belzile, Dec 1, 2016 3:08 PM

Looks good to me. Is your ServerUrl set?

You are getting this error right after installation, right? You installed Coveo on a brand new instance and got this error?

Gravatar for swamcts@gmail.com

Comment by swamcts, Dec 1, 2016 4:15 PM

Yes i got this error on brand new instance of sitecore.

Severurl is set.

Gravatar for sbelzile@coveo.com

Comment by Sébastien Belzile, Dec 1, 2016 4:20 PM

Your 2 statements are conflictual. You did modify the configuration files? Is the serverUrl correct? Without telling us what the URL is (if this information is sensitive), could you provide its format?

Gravatar for swamcts@gmail.com

Comment by swamcts, Dec 1, 2016 4:26 PM

https://admin-stg.sss.com

Gravatar for swamcts@gmail.com

Comment by swamcts, Dec 1, 2016 4:27 PM

i have modified the config files as told by this link, https://developers.coveo.com/display/public/SitecoreV4/Setting+Up+Coveo+for+Sitecore+in+a+Remote+Server+Configuration+-+On-Premises

Gravatar for sbelzile@coveo.com

Comment by Sébastien Belzile, Dec 1, 2016 4:32 PM

I'm giving up.

Obviously, the problem is a misformed URL somewhere. If you could revise the steps you performed, maybe you will find the problem. Otherwise, wait for someone else to comment or see with Coveo support.

Gravatar for jflheureux@coveo.com

Comment by Jean-François L'Heureux, Dec 2, 2016 10:12 AM

Do you have a custom Link Manager / Link Provider on this Sitecore instance. If so, you should verify the validity of the links generated by this custom module. Coveo uses the links generated but validate them in the indexing process of items.

Ask a question