Gravatar for ethan.xu@agencyq.com

Question by ethanx, Dec 8, 2016 11:21 AM

No items in Content Browser while Source has 7,000+ items

Hi, I am new to Coveo and just got started on my first Coveo cloud installation. The problem I got is that after build my index for the first time I got 7,000+ items in the source but nothing in the content browser thus nothing in my search result.

And here is the log during the initial indexing:

ManagedPoolThread #1 14:54:46 INFO  [Rebuilding source "Coveo_index"] Waiting for documents to be searchable...
ManagedPoolThread #1 14:54:46 INFO  [Rebuilding source "Coveo_index"] Committed documents: 0 / 7652
ManagedPoolThread #1 15:02:17 WARN  [Rebuilding source "Coveo_index"] Inactivity timeout expired. Not all documents were committed in the allotted time (00:05:00). This might be due to the Coveo Cloud being unable to connect to the Sitecore instance.
ManagedPoolThread #1 15:02:17 INFO  [Rebuilding source "Coveo_index"] Documents are searchable.
ManagedPoolThread #1 15:02:18 INFO  [Rebuilding source "Coveo_index"] Rebuild finished.

I searched all over the internet and coveo forum but found nothing. Do anyone have any idea on how to fix it?

1 Reply
Gravatar for dberube@coveo.com

Answer by Dominic Berube, Dec 8, 2016 11:49 AM

Hi Ethan,

Which version (4.0.?) of Coveo for Sitecore are you using?

If you are not on 4.0.450 or 4.0.704 and you have documents that are not accessible by an anonymous user, your Sitecore instance needs to be reachable from the outside so the Sitecore securities can be expanded.

If you go to the Coveo Cloud Platform admin console and click on the Security Identities menu item on the left, you should see a Sitecore Security Provider for [YOUR INSTANCE NAME]. If you see Identities in error, it's probably because the Cloud Platform can't reach your Sitecore instance and why your documents are not visible.

You can also select your source and Open in Content Browser, click the (…) button at top-right corner and Preferences, you will see an option called View all content. This option allows you to see all the content, even the documents that are secured.

Dom

Gravatar for ethan.xu@agencyq.com

Comment by ethanx, Dec 8, 2016 12:20 PM

Thank you so much, Dom, I do see the items when I check "View all content" option.

However, I am using Coveo 4.0.704 and I have no error in the Security Identities. And I checked the access viewer of the items, they are all accessible by default/anonymous and extranet/anonymous users, although there are other security settings restricting content editors.

I am not sure how I can fix this. I cannot upgrade Coveo anymore, no error to fix in security identities, and anonymous users already have access to the items…

Gravatar for dberube@coveo.com

Comment by Dominic Berube, Dec 8, 2016 2:05 PM

Ok, in this case, you should open a support ticket to Coveo with all the information you have.

Just to make sure, can you validate that the content editor roles the documents are restricted to are actually present in Sitecore. Also, if you check the Details of a document, in the Content Browser, there is a Permissions tab where you should see the effective permissions on the document.

Gravatar for ethan.xu@agencyq.com

Comment by ethanx, Dec 8, 2016 3:52 PM

Thanks, Dom! That's really helpful!

I followed your instruction and checked the Sitecore role manager, to my surprise the roles showed in access viewer don't exist in the role manager (inherited DB from others, no idea why roles were missing). So I created the roles, resynced the security identities, and rebuilt the index. Now all items are showing in the content browser. I just can't thank you enough!

Ask a question