Gravatar for dsoriano@littelfuse.com

Question by Dean, Dec 19, 2016 8:18 PM

"Unchanged" status in indexing after publish or reindexing

Hi,

We are noticing something odd every now and then with our setup. When we update some media items' file and then republish, Coveo sees them as 'unchanged' and does not update the index. We tried forcing the reindex using the Developer tab in Sitecore but the same 'unchanged' status remains.

The only time we can clear things out is if we do a full reindex using the Indexing manager.

What could be the possible reason for this.

We are using SC8.1 update 3 and CES 7.0 (8541) Thanks

Gravatar for dsoriano@littelfuse.com

Comment by Dean, Dec 26, 2016 4:24 PM

Hi,

ANyone have any ideas?

Thanks

Gravatar for sbelzile@coveo.com

Comment by Sébastien Belzile, Dec 27, 2016 10:49 AM

What is your version of Coveo for Sitecore?

Does it remain unchanged if you update the "binary content" (attached file) only?

If you update any other field, is the item still marked as "unchanged"?

Gravatar for dsoriano@littelfuse.com

Comment by Dean, Dec 29, 2016 1:59 AM

We use CFS 8.1 3.0 1332 We noticed that there are instances when we update the File (binary content), it doesn't seem to 'see' that anything changed. For other fields, I think it updates

1 Reply
Gravatar for jflheureux@coveo.com

Answer by Jean-François L'Heureux, Jan 2, 2017 11:18 AM

I think this behavior is expected.

Coveo for Sitecore and the Coveo index are using the "Updated" Sitecore standard field to know whether an indexed item is out of date. If the binary of a media item is modified but its "Updated" field is not, Coveo will think the indexed version is up to date.

I hope this helps.

Jeff

Ask a question