Gravatar for alexlin@inserso.com

Question by exodues, Jan 19, 2017 11:04 AM

Coveo for Sitecore - no index source was created and unable to create new index source

I've installed CES7, Coveo Search API and Coveo for Sitecore 4.0 for 3 identical Sitecore 8.2 sites on different servers. Only one Sitecore site has the index sources created successfully; while the other do not have any when checking the CES admin web tool.

I'm not sure when the Coveo index source is created during the installation. My assumption is that they are created during the package installation for "Coveo for Sitecore".

I was trying to following the following instructions to manually create a source, but the Sitecore is not listed in the source type https://onlinehelp.coveo.com/en/ces/7.0/administrator/configuringandindexingasitecore_source.htm

We are using a paid license "Coveo for Sitecore V4 Pro on Premise" and use the cloud platform (https://platform.cloud.coveo.com) to connect the site to the license. Coveo told us the license file is no longer be used.

Without the source, the index cannot be built. Is there other way we can manually create the index?

I've also reinstalled the Coveo for Sitecore package but the installation wizard no longer show up. Should I recreate the whole Sitecore instance and start all over?

1 Reply
Gravatar for dberube@coveo.com

Answer by Dominic Berube, Jan 19, 2017 11:13 AM

Hi,

You need to use the Indexing Manager from the Control Panel to create the sources and index the content of your Sitecore in CES. You can also use the Coveo menu to Synchronize CES Configuration, this will only create the sources, security providers and fields and not index any documents though. See this documentation.

The reason why you are not seeing the installation wizard the second time you reinstalled the Coveo for Sitecore package is that the Coveo for Sitecore configuration files are already activated. They are located in the Coveo folder of the App_Config\Include folder of your Sitecore instance. You can disable them by renaming them .config.disable if you want to see the installation wizard again after the installation of the package.

Dom

Ask a question