Gravatar for pglaurin@coveo.com

Question by pglaurin, Jan 26, 2017 6:09 PM

Error while performing JWT flow for the requested user

We are getting an error in Communities when trying to use Coveo search.

{
  "message": "Request Error : Error while performing JWT flow for the requested user.",
  "status": 400,
  "type": "Ajax Error (status: 400)",
  "name": "Ajax Error (status: 400)"
}

I am guessing it is something to do with the remote site settings. Let me know what changes I need to make.

4 Replies
Gravatar for mlaporte@coveo.com

Answer by Martin Laporte, Jan 27, 2017 3:37 AM

Since we got Support Login Access to the org we had a quick look and the issue was that a Profile was missing in the Coveo for Salesforce application. Some profiles were added (no doubt while following the instructions in the documentation), but the one for the administrator user was missing and caused users of this profile to get that error. We plan on improving the message for this in a future version, of course.

We tried adding the profile and confirmed that search page worked afterwards, and then reverted the fix because we prefer letting admins manage their own security settings. So just adding it back should do the trick. I won't detail the name of the profiles here since this is a public site, but I'll see that this info is sent by email as well.

Gravatar for gminero@coveo.com

Answer by gminero, Jan 26, 2017 9:36 PM

It would appear that the users permission set requires access to the Coveo connected app. Please let us know if you still get:

, "status": 400, "type": "Ajax Error (status: 400)", "name": "Ajax Error (status: 400)" }

after the appropriate permission set has been granted access to the connected app.

Thanks

Gravatar for mmoody@smarsh.com

Answer by megmoo, Jul 12, 2017 11:19 PM

@Martin Laporte I am trying to configure Coveo in our sandbox for our lightning community. I'm getting the above error. I have checked that the Sys Admin profile is authorized for the Conveo for Salesforce in the Connected Apps section. Does this error occur in any other situations?

Gravatar for mlaporte@coveo.com

Answer by Martin Laporte, Jul 13, 2017 7:23 AM

Did you follow the steps described here https://developers.coveo.com/display/SalesforceV2/Step+3+-+Allowing+User+Impersonation? Including the part about setting users to Pre-Authorized.

Otherwise, are you using a custom DNS on your community (ex: something not under .force.com)?

If you're OK with granting us Subscriber Access we can have a look if you wish.

Ask a question