Gravatar for ylakhdar@coveo.com

Question by Yassine Lakhdar, Feb 14, 2017 11:07 AM

Disable Facet collapse not working

Hi,

I am trying to remove the ability to collapse and expand a facet from a Salesforce page. I used the UI Editor to remove the collapse option and this is the generated code:

div class="CoveoFacet" data-title="Type" data-field="@objecttype" data-tab="All" data-enable-collapse="false"

However, the collapse button is still there.

Am I missing something?

Thank you

1 Reply
Gravatar for gminero@coveo.com

Answer by gminero, Feb 14, 2017 11:33 AM

I believe you are referring to the data-enable-more-less component rather than the collapse, is that possible? Please view the below screenshot:

alt text

In order to disable it, from the Interface editor, when you select the facet, scroll down to the enable more/less button and uncheck it:

alt text

Let me know if this is not the case. Thanks

Gravatar for ylakhdar@coveo.com

Comment by Yassine Lakhdar, Feb 14, 2017 11:44 AM

No, it is really the facet collapse option. I cleared the checkbox but I still can see the collapse button UI editor

As you can see, the collapse button is still there. Search page

Can you reproduce this behavior?

Gravatar for gminero@coveo.com

Comment by gminero, Feb 14, 2017 12:03 PM

In that case, you have to make sure you do this for each facet. Could you share your current Coveo for salesforce package version?

Gravatar for bblais@coveo.com

Comment by tha boss, Feb 15, 2017 10:57 AM

here's the version we're using : 2.35 Uninstall | Configure Managed - Installed Coveo for Salesforce V2 Coveo Solutions inc 2.35 CoveoV2 Active Unlimited 0 21/12/2050 21/12/2016 1:43 PM Not Checked 1 5 3

Gravatar for gminero@coveo.com

Comment by gminero, Feb 15, 2017 2:30 PM

Using the latest package (2.38) I am unable to reproduce. I yet have to confirm using 2.35.

Ask a question