Gravatar for dmarkovic@socialthinking.com

Question by Darko Markovic, Jun 5, 2017 8:29 AM

Free Text Queries deselect after rebuild indexes

Hi Coveo Team,

We have a problem with configuring Free Text Search for our search field TITLE.

When we select "Include for free text queries" field for our custom field and do rebuild indexes this field becomes deselected.

We tried with adding following line in Coveo.SearchProvider.Custom.config

<fieldType fieldName="title" isFacet="true" isMultiValue="false" isSortable="true" includeForFreeTextSearch="true" settingType="Coveo.Framework.Configuration.FieldConfiguration, Coveo.Framework" returnType="System.String" />

but search by Title field value does not work.

Our environment is:

Sitecore 8.1.160302

Coveo For Sitecore 4.0.704.0

CES 7.0.8541.0

Gravatar for sbelzile@coveo.com

Comment by Sébastien Belzile, Jun 5, 2017 10:45 AM

  1. Sitecore configuration will override platform changes. It is normal that if you select `includeForFreeTextSearch` in the Coveo Cloud platform, your change will be overridden.
  2. The config node is the way to go. => Did you reindex after making this change?
Gravatar for dmarkovic@socialthinking.com

Comment by Darko Markovic, Jun 5, 2017 11:19 AM

Hi Sebastien,

Thanks for answer.

Initially my config file was without includeForFreeTextSearch config.

I tried to select Include for free text queries => Apply Changes => Rebuild indexes

After that Include for free text queries is un-checked.

I tried to setup includeForFreeTextSearch=true in config file => rebuild indexes but free text search does not work again.

1 Reply
Gravatar for dmarkovic@socialthinking.com

Answer by Darko Markovic, Jun 5, 2017 8:12 PM

Hi Coveo Team,

Sorry for inconvenience but I found another config file which is loading after Coveo.SearchProvider.Custom.config which returning includeForFreeTextSearch to false.

So the best option for making some field free for Text search is includeForFreeTextSearch=true.

Ask a question