Gravatar for aviral.sinha@honeywell.com

Question by aviral.sinha, Jun 19, 2017 7:22 AM

Getting Error in Coveo Search API and Security Provider

I have installed the below Coveo products on my machine

  • Coveo Enterprise Search 7.0 x64 (7711) for Sitecore
  • Coveo Search API Coveo Search API 8.0.543
  • Coveo for Sitecore (local) - Coveo for Sitecore 80 3.0 (1055).zip

The Sitecore version I am using is Sitecore 8.0 rev. 150812

After successful installation of all the Coveo products as per the installation guidelines, the diagnostic page shows the following errors in

Coveo Search REST Endpoint ()

The remote server returned an error: (503) Server Unavailable. (Hide details)
System.Net.WebException: The remote server returned an error: (503) Server Unavailable.
   at System.Net.HttpWebRequest.GetResponse()
   at Coveo.SearchProvider.Applications.StateVerifier.<>cDisplayClassd.<GetRestEndpointState>bc()
   at Coveo.SearchProvider.Applications.BaseVerifier.VerifyComponent(Func`1 pVerifyMethod, String pComponentName)

Coveo Security Provider: In error

I have already tried the below proposed solutions on answers.coveo.com and many more

  • https://answers.coveo.com/questions/6301/rest-endpoint-and-security-service-unable-to-conne.html
  • https://answers.coveo.com/questions/8952/exception-while-processing-an-item-unable-to-conne.html
  • https://answers.coveo.com/questions/10077/error-on-coveo-installation-httpyoursitecoreinstan.html

All the installations are done on the same server locally for a development purpose Could you please help me out here?

The error screen shot in the Admin tool

admin-tool-screenshot.png

Gravatar for sbelzile@coveo.com

Comment by Sébastien Belzile, Jun 19, 2017 10:28 AM

We will need more informations. Could you look at your Sitecore logs? See what exceptions come out?

Gravatar for aviral.sinha@honeywell.com

Comment by aviral.sinha, Jun 19, 2017 3:31 PM

log.zip

PFA the Sitecore log file. The only error I can see is

The remote server returned an error:(503)ServerUnavailable.(Hide details)

System.Net.WebException:The remote server returned an error:(503)Server Unavailable.

at System.Net.HttpWebRequest.GetResponse()

at Coveo.SearchProvider.Applications.StateVerifier.<>c__DisplayClassd.<GetRestEndpointState>b_()

1 Reply
Gravatar for sbelzile@coveo.com

Answer by Sébastien Belzile, Jun 19, 2017 10:35 AM

According to my compatibility tables here, Coveo for Sitecore 3.0.1055 does not support Sitecore 8.0.150812.

This might be the cause.

Coveo for Sitecore 3.0.1055 supports up to Sitecore 8.0u3.

8.0.150812 is Sitecore 8.0u5. Support for this version has been added in CoveoForSitecore 3.0.1116.

Gravatar for aviral.sinha@honeywell.com

Comment by aviral.sinha, Jun 19, 2017 3:34 PM

coveo-diagnostic-page.png

Also, PFA coveo diagnostic page screenshot, which shows that

Coveo for Sitecore 3.0.1055 is compatible with Sitecore 8.0.150812.

Ask a question