Gravatar for info@eat-sleep-code.com

Question by eat-sleep-code.com, Oct 12, 2017 8:35 PM

clickableUri contains a URL that isn't valid

I am new to Coveo for Sitecore. I am just setting up our initial non-production instance.

For corporate privacy reasons, we shall say the server URL should by https://dev.example.com

Most of the urls are being generated with a domain of "https://www.exampledev.com" I have no idea where this is coming from.

I have:

  • searched through the Web.config file
  • searched the output of showconfig.aspx
  • searched through the SiteDefinition.config,
  • looked at the IIS host headers on the server
  • searched through all of the /App_Config/Include/Coveo/ files.

"exampledev" does not appear in any of those locations.

But nearly all my items clickableuri has "exampledev.com" in it, as well as I received this error:

 Coveo.Framework.Utils.Rest.HttpClientException: Failed to obtain resource located at 'https://www.exampledev.com/coveo/rest?pipeline='. See inner exception for details. 

I am using Sitecore 8.2 Update 2 with Coveo for Sitecore 4.1.82.12 (Enterprise Cloud).

1 Reply
Gravatar for jflheureux@coveo.com

Answer by Jean-François L'Heureux, Oct 13, 2017 12:35 PM

Hi,

Thank you for the very detailed question. Given the absence of the domain in the Sitecore configuration files, I would recommend checking if you have a network proxy, load balancer, or an URL rewrite module in IIS. Those are able to rewrite URLs and cause similar issues. If you do not find anything, I recommend you to open a support ticket to Coveo support as this issue would be very hard to troubleshoot in a Q&A website.

I hope this helps,

Jeff

Gravatar for info@eat-sleep-code.com

Comment by eat-sleep-code.com, Oct 16, 2017 6:19 PM

Thanks. We have a ticket open with support now. I will post what the resolution was when they have responded.

Ask a question