Gravatar for bciancio@trident-it.com

Question by bciancio, Nov 27, 2017 4:45 PM

Facet not applying on certain results

We are using the free/express edition of CoveoV2 for Salesforce using Visualforce pages/components.

Package Version: Coveo for SalesforceV2 - 2.48

Issue: Certain results are always appearing if:

a) filter expression matches (expected)

b) facet does not meet criteria (not expected)

Scenario: Facet value "Cloud" when selected still shows Result_A which doesn't have "Cloud" in the associated facet field. URL: #t=All&sort=relevancy&f:@SfProvider_Filters__c=[Cloud]&f:@SfProvider_Filters__c:operator=or

Notes:

1) Went to Network>V2 and was trying to discover the reasoning:

- None of the results were marked as an isTopResult

- isRecommendation is true on the items that seem to be returning.

2) Results are still respecting:

- sharing model

- objecttype filters (tab)

We had a similar issue in the past, noted here. I reviewed and believe that the main difference is that previously results outside of sharing/permission model was appearing. Now its specific to Facets criteria not being applied for certain records?

I guess my question would be do results with: rankingModifier: is "Reveal ART" that are boosted by Coveo's Automated Relevancy Tuning ignore facets? If yes solutions? If no any suggestions on how we should move forward with our debugging?

3 Replies
Gravatar for dreisch@coveo.com

Answer by David, Nov 29, 2017 9:41 PM

This feature is not yet supported in Coveo Free. This means that for now you cannot prevent those results from ML from being included even though they do not match.

Sorry for the inconvenience, but this is on our roadmap!

Gravatar for dreisch@coveo.com

Answer by David, Nov 27, 2017 5:36 PM

Hi,

Normally when you enable ART on your pipelines in the Coveo Administration Console there are two options:

"Match the query"

"Match the advanced query"

The "advanced" box is usually selected by default and should ensure that facets are factored into your results even when using ART.

Could you verify your configuration?

Gravatar for bciancio@trident-it.com

Comment by bciancio, Nov 27, 2017 5:58 PM

I can confirm that the "advanced" box is checked.

Gravatar for dreisch@coveo.com

Answer by David, Nov 29, 2017 8:01 PM

Thanks for checking @bciancio. I'm still investgating this.

Ask a question