Gravatar for ralph.framke@medica.com

Question by ralphframke, Feb 21, 2018 4:22 PM

Coveo TLS 1.1 Question

Hi,

Please can you confirm if the following support article only applied to cloud or is it required for on-prem as well?

https://support.coveo.com/s/article/3022

Gravatar for ralph.framke@medica.com

Comment by ralphframke, Mar 2, 2018 7:21 PM

Assuming all the configuration for TLS is complete and validated per steps, as pre-caution, how does one verify connection for Coveo On-Prem overall to Coveo Cloud for license still works? Are there any behavior in software that would immediately make us aware? For example, would software stop working immediately if there a problem?

1 Reply
Gravatar for mlaporte@coveo.com

Answer by Martin Laporte, Feb 22, 2018 10:26 AM

If you are 100% on-premises, our removing of TLS 1.0 support in our Cloud Platform doesn't impact you. For Sitecore, if you are using our Cloud-based UA service (as stated in the article), you might have to ensure that your server supports talking to a non TLS 1.0 endpoint.

Gravatar for jflheureux@coveo.com

Comment by Jean-François L'Heureux, Feb 27, 2018 10:25 AM

@Martin Laporte is right. Coveo for Sitecore on-premises editions are using Coveo Cloud to store their licences, send events to the Coveo Usage Analytics service, and retrieve information from this service as well.

Thus, it also applies to on-premises installations.

Starting with the March 2016 (3.0.1266) release of Coveo for Sitecore, it supports TLS 1.1 and 1.2. All releases of Coveo for Sitecore 4.0 and 4.1 are supporting those protocols as well. If you have one of these versions, the software automatically uses the most secure protocol by default.

If you are using Coveo for Sitecore 3.0 between February 2015 (3.0.955) and January 2016 (3.0.1226) releases inclusive, you can install an additional package to support TLS 1.1 and 1.2: https://developers.coveo.com/x/coIKAg

If you are using an older release of Coveo for Sitecore, you have to upgrade.

Gravatar for ralph.framke@medica.com

Comment by ralphframke, Mar 2, 2018 4:11 PM

Thank you for the helpful information. I had a couple more question and wondering if you would know. I am assuming that Coveo Enterprise is also impacted by this so would the following versions by default support TLS 1.1 and/or TLS 1.2 or is an upgrade required:

7.0 x64 Build 8691.0
7.0 x64 Build 8225.0
7.0 x64 Build 9167.0

Thanks in advance. Also, would you know if there is a way to test to ensure that after settings are applied, that licences still work? We will like to validate all changes prior to deadline.

Thanks again for all the help!

Gravatar for ralph.framke@medica.com

Comment by ralphframke, Mar 2, 2018 5:02 PM

thank you!

Ask a question