Gravatar for richard.stokes@medica.com

Question by mnrichardstokes, Feb 22, 2018 5:55 AM

Prevent MongoDB Access in Search Page

I am using a custom build Coveo for Sitecore 4.0 search page and if MongoDB is unavailable it errors out. I cannot figure out how to prevent this.

I can have only this one line as part of my custom page and it will still try to contact MongoDB and if it is not available it will time out and error out.

<%@ Control Language="c#" AutoEventWireup="true" Inherits="Coveo.UI.CoveoSearch" TargetSchema="http://schemas.microsoft.com/intellisense/ie5" %>

The Coveo version is 4.0.1520 and the SItecore version is 8.2.5

In the control presentation, I disable both the Coveo Analytics and Sitecore Analytics and have verified this by the Final Renderings raw view.

I was expecting that the communication to MongoDB would be async and would not error out.

What am I missing? I had to turn off Sitecore Analytics off in production because of this issue.

Gravatar for flguillemette@coveo.com

Comment by François Lachance-Guillemette, Feb 22, 2018 12:55 PM

Do you have the exact error that pops when MongoDB is not available? It might give us a clue about what is trying to call the Analytics.

We do not use MongoDB directly in Coveo for Sitecore, we call Sitecore's API through the `Sitecore.Analytics.Tracker`, I suspect something might be throwing the error in there.

Also, can you confirm that _only_ the search interface is breaking when MongoDB is down?

Gravatar for maninder.kaur@xcentium.com

Comment by Nicky, Feb 13, 2019 3:20 PM

Did you get a solution for this issue?

0 Reply
Ask a question