Gravatar for rrvinchurkar@gmail.com

Question by rita.vinchurkar, May 24, 2018 10:21 AM

Coveo Field configurations not updating on template modification

We have Sitecore 7.2 application with CES 7. We updated template field type from "Single Line Text" to "Number" and published changes to web database then rebuilt indexes. Our expectation was Coveo field configurations will be updated in Admin tool from "String" to "Numeric" so that we can perform range based search.

Login CES admin > Configurations > Fields > web or master field set

Please let us know what can be done to achieve this. Are we missing any step?

Gravatar for flguillemette@coveo.com

Comment by François Lachance-Guillemette, May 24, 2018 5:28 PM

Usually, any indexing operation should update the configuration and the fields.

It there an hard-coded type in your field map? You can validate this in the `Coveo.SearchProvider.Custom.config` file.

Also, can you provide your full Coveo for Sitecore version? (for instance, 4.1.342.10)

1 Reply
Gravatar for rrvinchurkar@gmail.com

Answer by rita.vinchurkar, May 25, 2018 5:25 AM

Hi @François Lachance-Guillemette,

We had fieldType entries in config but String or Numeric was not mentioned anywhere, please check this.

<fieldType fieldName="min avail sq ft" isSortable="true" includeForFreeTextSearch="false" settingType="Coveo.Framework.Configuration.FieldConfiguration, Coveo.Framework" />

We are using below versions:

  • Coveo for Sitecore 72 3.0 (1367)
  • Sitecore.NET 7.2 (rev. 141226)
  • Coveo Enterprise Search 7

We removed config entries for fieldTypes and it worked. Thank you so much @François Lachance-Guillemette, configurations are updated in CES now.


Thanks a lot,
Rita

Ask a question